[panic] 6.0 Beta1 can`t boot - acpi_pci_link_add_reference: apparently invalid index 27

John Baldwin jhb at FreeBSD.org
Tue Aug 2 19:43:41 GMT 2005


On Monday 01 August 2005 03:06 pm, Alex Lyashkov wrote:
> В Пнд, 01.08.2005, в 21:10, John Baldwin пишет:
> > On Saturday 23 July 2005 03:57 pm, Alex Lyashkov wrote:
> > > > Need to see your acpidump -t -d output.  It appears your _PRT table
> > > > has an invalid reference to a link (one that doesn't exist.)
> > > >
> > > > --
> > >
> > > requested output is attached.
> > > this box i has are acpi problems early.
> > > At 5.2-Current box have interrupt storm, but later it`s fixed.
> >
> > It seems your ASL output didn't make it through.  Probably it is a bug in
> > your ASL that you can fix by removing the reference to the link (i.e.
> > it's probably supposed to be a hardwired IRQ 27).
>
> but FreeBSD 5.4 work fine at this box....

That's because the pci_link code was rewritten in 6.x to better support link 
devices.  As indicated in private e-mail, your ASL most certainly has a bug 
and the OS is simply do what the ASL tells it to.

-- 
John Baldwin <jhb at FreeBSD.org>  <><  http://www.FreeBSD.org/~jhb/
"Power Users Use the Power to Serve"  =  http://www.FreeBSD.org


More information about the freebsd-current mailing list