Compaq v2310 revisited in 32-bit mode

Pete Carah pete at altadena.net
Mon Aug 1 20:33:06 GMT 2005


I gave up on keeping my new amd64 compaq in 64-bit mode due mostly to the
lack of 64-bit drivers even from HP.  Even the PCcard driver only kind-of
worked...

The pc-card works in 32bit mode; in fbsd/amd64 it hung the system whenever
a card (Dlink ath card) was plugged in, then resumed whenever it was 
unplugged.  This works fine in 32-bit (I'm typing through it now).

There is no 64-bit Broadcom driver out there that I could find that 
handled the 4318.  Linuxant.com had a 64bit driver that, when the
.inf was patched to recognize the 4318, did so, but fbsd never attached 
the ndis driver due to a timeout.  The 32bit driver is better but doesn't
handle WPA.  (in fact nothing shows up in "list scan" so something
fundamental is wrong.  I got the driver out of my own 
/windows/system32/drivers directory so I know it works in windoze (WPA 
works fine in windows on the same access point).

I get reboots whenever trying X11 on the ATI chipset in this machine,
using the .12 or .16 snapshot at xorg.  Eric and JKim: This happens also 
in 32-bit mode (I was wishing :-)

So, the TI cardbus driver lacks something in 64-bit mode and the ndisulator
is better (but might be OK if Broadcom released a 64-bit driver for the 
4318...) (and even better if they did something like atheros and released 
a layered driver to handle the nda stuff, but I'm not holding my breath...)

Also, I couldn't get the CD boot to work (in fact, the generic kernel
in general) without disabling a bunch of stuff in hints.  I still haven't
quite figured out what it is but it partly seems to be atapi_dma.

Still progress needed.  If anyone involved in the hardware effort (especially
X11) lives in Southern Calif, I can help with some access to the hardware.  

I do have the TI datasheet (all 300 pages) for the chip that handles the 
pccard (also fw and the built-in flash-card reader/writer).  I never tried 
fw in 64-bit mode to see if that part of the driver worked.  Once I get some
time I can look into the relevant drivers to see what is going on there.  
It may be that some address masking/bounce-buffer stuff needs to be done...  
(or does the amd64 port always assign addresses that fit into 32 bits if 
there is less than 4g ram present?)  Again, all this works fine in windoze 
(32-bit mode again; HP isn't (yet) participating in the MS 64-bit XP 
exchange program, maybe thanks to Broadcom?).  (though I also don't know
about ATI...)

USB and ATA do work in 64-bit; those are in the main ATI chipset.  I think
that atapi_dma doesn't but don't know for sure since the only symptom I see
is a hang before the geom printouts during boot.  (and that could be the
drive and not the chipset anyhow?)  I've kept verbose dmesg and several
xorg logs from the 64-bit phase in case.  
(http://www.altadena.net/~pete/amd64/)

-- Pete


More information about the freebsd-current mailing list