SMP on Compaq DL380

Matthew Sullivan matthew at
Tue Apr 26 17:51:17 PDT 2005

Maxime Henrion wrote:

>Doug White wrote:
>>This appears to be the latest BIOS. Some Compaq systems are known to
>>generate bogus MPTables and such when configured to run Windows. You might
>>poke around the BIOS Setup and see if there is an "OS Type" field that can
>>be set to "SCO UNIX" or "Other" (not in PnP setup probably).
>Yeah, I've seen DL380 boxes that needed "Linux" as the OS type or the
>BIOS wouldn't generate an MPTable with both CPUs.
Apologies for any wasted time....

This was the answer....

In detail, this morning I went back into the Compaq BIOS configuration 
tool, and the OS's settable were (amongst others):


I had set to 'UNIX'.... I changed to 'OTHER' rebooted and .. still the same.

There was no mention of 'LINUX' ... frustrated (and sure I saw "LINUX" 
in the config previously) I did the following...

1/. Powered Down
2/ Undocked all SCSI drives (just popped them out of the connectors)
3/ Booted the Config utility
4/ Selected 'Erase System'
5/ Power cycled (as instructed)
6/ Booted back into the 'Smartstart' config utility.
7/ Followed the 'Manual Configuration and OS install'
8/ Selected "LINUX" (which was now on this menu.
9/ Went to the Smart Array Util, and exited immediately, which caused a 
spontaneous reboot.
10/ Powered Down
11/ Docked all the drives.
12/ Powered up, and booted back into the Smart Start util.
13/ Noticed the RAID 5 array and config was self configured by the 
14/ Checked all settings in the Configutil - noticed "LINUX" was still 
displayed as the OS type.
15/ Checked the Array config (very impressed that it worked out the 
config itself)
16/ Exited Util (no save, none necessary).
17/ Power cycled.
18/ Removed smart start CD.
19/ booted FreeBSD and saved the collected data in a similar place:

...and as you can see, I have 2 CPU's and this time they are detected 
correctly (including the 'odd' CPU type that was reported by the 
previous config)....

For this I hope someone will create a FAQ for old Compaq's, and I'm 
posting this back to the list so that people having similar problems in 
the future can reference it.

Thanks for all your help people.


Matthew Sullivan
Specialist Systems Programmer
Information Technology Services
The University of Queensland

-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/x-pkcs7-signature
Size: 2666 bytes
Desc: S/MIME Cryptographic Signature
Url :

More information about the freebsd-current mailing list