problem with debug.mpsafenet (was: Problems with ANA-6944A + 5.3-BETA + IRQ sharing?)

Oliver Lehmann lehmann at
Mon Sep 27 12:23:45 PDT 2004


I tried now 3 FreeBSD versions.

	PI-166MHz, 64MB RAM
	de0             irq9 @ANA-6944A
	de1	irq9 @ANA-6944A
	de2	irq9 @ANA-6944A
	de3             irq9 @ANA-6944A
        xl0             irq12
        xl1             irq10
	ep0             irq5
	ep1             irq7
	/mnt/files is a nfs mount from
	3 * ssh sessions from to
	2 * dd if=/mnt/files/dill_dd of=/dev/null
	1 * ping running

4.7 (GENERIC kernel):

It just works, no errors, no strange things happend, even if I started
some ping -f's -> The times from pinging -> stayed normal and didn't changed in no way (constant 0.3 - 0.5
the two dd's (interrupted):
3334870016 bytes transferred in 3047.149719 secs (1094423 bytes/sec)
3334299648 bytes transferred in 3047.058924 secs (1094268 bytes/sec)

5.2.1 (Kernel with IPFIREWALL enabled - firewall set to OPEN):

With an old 5.2.1 harddisk I'm getting strange errors.
100 ping packets transfered succesfully within a normal timeframe. After
that, the whole Network card doesn't respond. The system showed me that my
nfs server wouldn't respond any longer. Network is completely b0rken.
I logged in to a local console, and tried to ping After waiting
some time "Host down" showed up.
Then I tried to use the two xl cards which are in that system too.
"ifconfig xl0 netmask" -> xl0: no memory for list
buffers. netstat -m showed me 5%/2% mbuf/cluster in use.
I rebooted the system, and started the same procedure, using xl0 and xl1.
I got no error, everything worked fine with xl (ok, it is somewhat
1089172480 bytes transferred in 1773.870397 secs (614009 bytes/sec)
1089825792 bytes transferred in 1774.109517 secs (614295 bytes/sec)

5.3-BETA6 (GENERIC Kernel):

Everything looked fine (exept same slowness as 5.2.1) for a while (~9min).
400736256 bytes transferred in 546.111599 secs (733799 bytes/sec)
414572544 bytes transferred in 565.398805 secs (733239 bytes/sec)

But as I started a ping -f from to The ping times
from to went up, and didn't renormalized after I break
the ping -f

64 bytes from icmp_seq=355 ttl=64 time=4.039 ms
64 bytes from icmp_seq=356 ttl=64 time=4.801 ms
64 bytes from icmp_seq=357 ttl=64 time=6.702 ms
64 bytes from icmp_seq=358 ttl=64 time=9.290 ms
64 bytes from icmp_seq=359 ttl=64 time=10.543 ms
64 bytes from icmp_seq=360 ttl=64 time=9.989 ms
64 bytes from icmp_seq=361 ttl=64 time=25.966 ms
64 bytes from icmp_seq=362 ttl=64 time=25.262 ms
64 bytes from icmp_seq=363 ttl=64 time=27.746 ms
64 bytes from icmp_seq=364 ttl=64 time=30.859 ms
64 bytes from icmp_seq=365 ttl=64 time=31.507 ms
64 bytes from icmp_seq=366 ttl=64 time=35.783 ms
64 bytes from icmp_seq=367 ttl=64 time=29295.367 ms
64 bytes from icmp_seq=368 ttl=64 time=28288.204 ms
64 bytes from icmp_seq=369 ttl=64 time=27279.969 ms
64 bytes from icmp_seq=370 ttl=64 time=26274.269 ms
64 bytes from icmp_seq=371 ttl=64 time=25267.441 ms
64 bytes from icmp_seq=372 ttl=64 time=24260.161 ms

After that, I added debug.mpsafenet=0 to /boot/loader.conf and rebooted
the system. I did the same as above. (2dd's, one ping from to, and one ping -f from to
The ping times from -> went a bit up (~0.3ms -> 0.6 -
1ms), but nothing else happend. dd finished w/o errors, no strange things
happend. (running now for ~20 mins w/o problems)

For me, It looks like there is a problem with mpsafenet!
Any help/patches to test/information requests/.... appreciated.

 Oliver Lehmann

More information about the freebsd-current mailing list