IRQ-Routing for 5.3-BETA

Matthias Schuendehuette msch at snafu.de
Sat Sep 25 12:26:39 PDT 2004


Hello Nate,

On Saturday 25 September 2004 19:43, Nate Lawson wrote:
> Matthias Schuendehuette wrote:
> > I reconfigured my ISDN-Card to use IRQ2/9 (which was more simple
> > than I remembered :-) and it works! Shame on me, sometimes it's
> > really too simple...
> >
> > This really works for FreeBSD 5.3-BETA5 of today, but it works
> > *only* with IRQ 2/9.
>
> I don't quite understand.  Your device's hardware was not set to 9
> but the BIOS was claiming it was?  Is it on the motherboard (i.e.,
> non-removable)?

No. The device is a "TELES S0/16.3" ISA nonPnP ISDN-Card, device 
isic(4), which can be software configured for various IRQ lines with
'hint.isic.0.irq="%d"' in /boot/device.hints.

This card was configured for IRQ 10 all the years and worked with that 
config since the very early days of isdn4bsd, IIRC on FreeBSD-3.x. This 
config worked with 5-CURRENT and ACPI as well until Aug 11, 16:00 UTC 
(approx.), where the new IRQ-Routing code came in. Until then, this 
ISA-Card had IRQ 10 exclusively (like it should be for ISA-Cards, IIRC) 
and the various PCI-devices shared IRQ-Lines 9, 11 and 12.

With the new code, the PCI-devices got IRQ-Lines 10(!), 11 and 12, so 
IRQ 10 was now shared between PCI-devices and the ISA card, which 
should not occur (isn't it?) and I thought that was the source of my 
new problems with this ISA-Device (I'm not quite sure anymore, see 
below).

After jhb's mail I patched on my head and said to me: If the new code 
really wants IRQ 10 for PCI devices, why not configure the ISA-Card for 
IRQ 9, which should be free now? This still works - if you can read 
this mail here... :-)

> > I also tried IRQ 5, which is not used by any other device (a least
> > I couldn't find any notice about irq5 in the boot -v messages but
> > for isic0), and this does not work with the same messages as with
> > IRQ 10.
> >
> > Somehow I have the uncertain feeling that the new IRQ-Routing code
> > has still some deficencies, at least for ISA-style IRQs...

I said this, because the isic(4)-device has IRQ 5 exclusively as well, 
no other PCI (or other legacy/ISA) devices have IRQ 5 on my system. But 
if I configured this ISA card to use IRQ 5, it doesn't work at all. So 
I'm not quite sure anymore if the problem (which came up when using IRQ 
10) is the not-allowed IRQ sharing (in case of IRQ 10) or if the new 
routing code has still some other problems with IRQs for ISA devices 
(or whatever) because IRQ 5 *has* to work for that ISA-Card in my 
HW-environment. What makes IRQ 9 so special?
 
> When the BIOS gives an initial irq, we always try to route to that
> one first since some devices don't work at any other irq.

I marked the appropriate IRQ in the BIOS as "ISA/nonPnP", so the marked 
IRQ *should* be assigned for the ISA card by the BIOS (but obviously 
isn't).

I hope I could clear the situation a bit.

I sure can switch to 6-CURRENT or at least try the new acpi_pci_link.c, 
but I don't believe that the problem is IRQ 9....

Thank you very much for your interest. I fear, these old ISA cards are 
no longer of public interest... :-)
-- 
Ciao/BSD - Matthias

Matthias Schuendehuette <msch [at] snafu.de>, Berlin (Germany)
PGP-Key at <pgp.mit.edu> and <wwwkeys.de.pgp.net> ID: 0xDDFB0A5F


More information about the freebsd-current mailing list