5.3-BETA5 PAE Panic/Problems

kdulzo at skoda.sockpuppet.org kdulzo at skoda.sockpuppet.org
Wed Sep 22 12:20:56 PDT 2004

  I've been searching around for what I might be doing incorrectly, but
seem to have come to a dead stop in setting up a HP Proliant DL380G3
machine with a PAE enabled 5.3-BETA kernel.  I've tried BETAS 3,4, and 5
with no luck.  The default PAE configuration file causes the problem
indicated in the log below.  FOO is a copy of PAE config with KDB, DDB,
and KVA_PAGES=512.  Am I incorrect in assuming this should work on 5.3?

(n.b. I also tried reducing the RAM from 8G to 5G with identical results)

At the atapci and the bge probe and attach phases the machine slugs for
150 seconds or so before continuing.  And of course, panics after
loading the kernel.

Kevin M. Dulzo

KDB: debugger backends: ddb
KDB: current backend: ddb
Copyright (c) 1992-2004 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
	The Regents of the University of California. All rights reserved.
FreeBSD 5.3-BETA5 #1: Mon Sep 20 16:55:12 CDT 2004
    kdulzo at jirayi-san:/usr/src/sys/i386/compile/FOO
ACPI APIC Table: <COMPAQ 00000083>
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: Intel(R) Xeon(TM) CPU 3.20GHz (3185.21-MHz 686-class CPU)
  Origin = "GenuineIntel"  Id = 0xf25  Stepping = 5
  Hyperthreading: 2 logical CPUs
real memory  = 8589930496 (8191 MB)
avail memory = 8149667840 (7772 MB)
FreeBSD/SMP: Multiprocessor System Detected: 4 CPUs
 cpu0 (BSP): APIC ID:  0
 cpu1 (AP): APIC ID:  1
 cpu2 (AP): APIC ID:  6
 cpu3 (AP): APIC ID:  7
MADT: Forcing active-low polarity and level trigger for SCI
ioapic0 <Version 1.1> irqs 0-15 on motherboard
ioapic1 <Version 1.1> irqs 16-31 on motherboard
ioapic2 <Version 1.1> irqs 32-47 on motherboard
ioapic3 <Version 1.1> irqs 48-63 on motherboard
acpi0: <COMPAQ P29> on motherboard
acpi0: Power Button (fixed)
Timecounter "ACPI-safe" frequency 3579545 Hz quality 1000
acpi_timer0: <32-bit timer at 3.579545MHz> port 0x920-0x923 on acpi0
cpu0: <ACPI CPU> on acpi0
cpu1: <ACPI CPU> on acpi0
cpu2: <ACPI CPU> on acpi0
cpu3: <ACPI CPU> on acpi0
acpi_tz0: <Thermal Zone> on acpi0
pcib0: <ACPI Host-PCI bridge> on acpi0
pci0: <ACPI PCI bus> on pcib0
pci0: <display, VGA> at device 3.0 (no driver attached)
pci0: <base peripheral> at device 4.0 (no driver attached)
pci0: <base peripheral> at device 4.2 (no driver attached)
isab0: <PCI-ISA bridge> at device 15.0 on pci0
isa0: <ISA bus> on isab0
atapci0: <ServerWorks CSB5 UDMA100 controller> port 0x2000-0x200f,0x376,0x170-0x177,0x3f6,0x1f0-0x1f7 at device 15.1 on pci0
ata0: channel #0 on atapci0
ata1: channel #1 on atapci0
pci0: <serial bus, USB> at device 15.2 (no driver attached)
pcib1: <ACPI Host-PCI bridge> on acpi0
pci1: <ACPI PCI bus> on pcib1
ciss0: <Compaq Smart Array 5i> port 0x3000-0x30ff mem 0xf7cf0000-0xf7cf3fff,0xf7dc0000-0xf7dfffff irq 30 at device 3.0 on pci1
pcib2: <ACPI Host-PCI bridge> on acpi0
pci2: <ACPI PCI bus> on pcib2
bge0: <Broadcom BCM5703 Gigabit Ethernet, ASIC rev. 0x1002> mem 0xf7ef0000-0xf7efffff irq 29 at device 1.0 on pci2
bge0: failed to allocate DMA resources
device_attach: bge0 attach returned 6
bge1: <Broadcom BCM5703 Gigabit Ethernet, ASIC rev. 0x1002> mem 0xf7ee0000-0xf7eeffff irq 31 at device 2.0 on pci2
bge1: failed to allocate DMA resources
device_attach: bge1 attach returned 6
pcib3: <ACPI Host-PCI bridge> on acpi0
pci3: <ACPI PCI bus> on pcib3
pcib4: <ACPI Host-PCI bridge> on acpi0
pci6: <ACPI PCI bus> on pcib4
pci6: <base peripheral> at device 30.0 (no driver attached)
atkbdc0: <Keyboard controller (i8042)> port 0x64,0x60 irq 1 on acpi0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
atkbd0: [GIANT-LOCKED]
sio0 port 0x3f8-0x3ff irq 4 on acpi0
sio0: type 16550A, console
fdc0: <floppy drive controller (FDE)> port 0x3f2-0x3f5 irq 6 drq 2 on acpi0
fdc0: [FAST]
fd0: <1440-KB 3.5" drive> on fdc0 drive 0
npx0: [FAST]
npx0: <math processor> on motherboard
npx0: INT 16 interface
orm0: <ISA Option ROMs> at iomem 0xee000-0xeffff,0xcc000-0xcd7ff,0xc8000-0xcbfff,0xc0000-0xc7fff on isa0
pmtimer0 on isa0
ppc0: parallel port not found.
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
sio1: configured irq 3 not in bitmap of probed irqs 0
sio1: port may not be enabled
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
Timecounters tick every 10.000 msec
ATAPI_RESET time = 30us
acd0: CDROM <COMPAQ CD-ROM SN-124/N104> at ata0-master PIO4
da0 at ciss0 bus 0 target 0 lun 0
da0: <COMPAQ RAID 0  VOLUME OK> Fixed Direct Access SCSI-0 device 
da0: 135.168MB/s transfers
da0: 34727MB (71122560 512 byte sectors: 255H 32S/T 8716C)
da1 at ciss0 bus 0 target 1 lun 0
da1: <COMPAQ RAID 5  VOLUME OK> Fixed Direct Access SCSI-0 device 
da1: 135.168MB/s transfers
da1: 104183MB (213367680 512 byte sectors: 255H 32S/T 26148C)
da2 at ciss0 bus 0 target 2 lun 0
da2: <COMPAQ RAID 0  VOLUME OK> Fixed Direct Access SCSI-0 device 
da2: 135.168MB/s transfers
da2: 34727MB (71122560 512 byte sectors: 255H 32S/T 8716C)
panic: vm_proc_new: upage allocation failed
cpuid = 0
KDB: enter: panic
[thread 0]
Stopped at      kdb_enter+0x2b: nop
db> where
kdb_enter(c0553a3d) at kdb_enter+0x2b
panic(c0562f2e,0,c03adbc7,ca2670a0,3) at panic+0x127
vm_proc_new(ca86ba80,ca2670a0,3,0,c087fc94) at vm_proc_new+0x30
proc_init(ca86ba80,1c0,103) at proc_init+0x1d
slab_zalloc(c0a232c0,103,7,ca386fc0,c0a20098) at slab_zalloc+0x331
uma_zone_slab(c0a232c0,3,2,10,18) at uma_zone_slab+0xd0
uma_zalloc_bucket(c0a232c0,3) at uma_zalloc_bucket+0x15c
uma_zalloc_arg(c0a232c0,0,2) at uma_zalloc_arg+0x27a
fork1(c05d8000,20034,0,c087fd50) at fork1+0x31f
kthread_create(c04cfd0c,0,c05f0df8,0,0,c0534b94,c0564107) at kthread_create+0x3d

kproc_start(c05c5c00,878020,878000,0,c0240ede) at kproc_start+0x1f
mi_startup() at mi_startup+0x96
begin() at begin+0x2c

More information about the freebsd-current mailing list