5.3-BETA5 panics when inserting dc0 carbus card (only with ACPI enabled) enabled)

Nate Lawson nate at root.org
Wed Sep 22 13:01:40 PDT 2004

Johan Karlsson wrote:
> On Wed, Sep 22, 2004 at 18:20 (+0200), Adrian Steinmann wrote:
>>I can confirm that this has been happening on my Thinkpad T20
> ...
>>since mid June.
>>When I build a kernel with date 20040613, I'm ok, then for 20040615
>>I have this probe problem, i.e.:
>>    cvs -qR -d /usr/cvs co -D20040615UTC sys - bad
>>    cvs -qR -d /usr/cvs co -D20040613UTC sys - good
> Using these dates and looking at the diffs, my guess is that this commit
> ----
> njl         2004-06-13 22:52:31 UTC
>   FreeBSD src repository
>   Modified files:
>     sys/dev/acpica       acpi.c acpi_acad.c acpi_button.c 
>                          acpi_cmbat.c acpi_ec.c acpi_isab.c 
>                          acpi_lid.c acpi_pcib_acpi.c 
>                          acpi_resource.c acpivar.h 
>   Log:
>   Add support to ACPI to manage its own resources. 
> ----
> is involved somehow. That is not to say that there is anything wrong
> with this commit, but something more might need to be fixed.
> I have not tried to verify if this is the offending commit, nor have I 
> tried to revert this commit alone since I guess that would fail missirably.
> Nate, do you think this commit might be the cause of our problem
> and if so is there any information we can provide.

Um, what is the dc0 card doing mapping ports 0-0xff:

Below the analogous output Johan Karlsson <johan at freebsd.org> posted
for his Xircom X3201 10/100BaseTX card for 5.3-BETA5:

dc0: <Netgear FA511 10/100BaseTX> port 0-0xff mem 0x88000000-0x880003ff 
at device 0.0 on cardbus0
cbb alloc res fail
dc0: couldn't map ports/memory

Dmesg from boot with a working kernel for dc0 would help as well as 
devinfo -r from a non-working one.


More information about the freebsd-current mailing list