Problems building BETA5

Axel S. Gruner axel.gruner at
Tue Sep 21 02:46:13 PDT 2004


I try to build the world with sources from today. So, "buildworld" runs
without an error, but "buildkernel" gives me always the same error (i
tried to delete /usr/obj, built the world again, cvsup new sources,...):

>>> stage 2.3: build tools
cd /usr/obj/usr/src/sys/PCS28;
MAKESRCPATH=/usr/src/sys/dev/aic7xxx/aicasm  make -DNO_CPU_CFLAGS -f
Warning: Object directory not changed from original
cc -O -pipe -nostdinc -I/usr/include -I.
-I/usr/src/sys/dev/aic7xxx/aicasm  -c
In file included from /usr/include/regex.h:4,
                 from /usr/include/regex.h:4,
                 from /usr/include/regex.h:4,
                 from /usr/include/regex.h:4,
                 from /usr/include/regex.h:4,
 from /usr/src/sys/dev/aic7xxx/aicasm/aicasm.c:49:
/usr/include/regex.h:3:23: #include nested too deeply
/usr/include/regex.h:4:32: #include nested too deeply
In file included from /usr/src/sys/dev/aic7xxx/aicasm/aicasm.c:63:
/usr/src/sys/dev/aic7xxx/aicasm/aicasm_symbol.h:112: error: syntax error
before "regex_t"
*** Error code 1

Stop in /usr/obj/usr/src/sys/PCS28.
*** Error code 1

Stop in /usr/src.
*** Error code 1

The only SCSI stuff i have in my kernel config is:

device          scbus           
device          ch             
device          da            
device          sa           
device          cd          
device          pass       

At the moment i  run FreeBSD 5.3-BETA4.
So, what could be the problem and how to solve it?

Thanks in advance.


More information about the freebsd-current mailing list