panic: APIC: Previous IPI is stuck

Andy Farkas andy at
Mon Sep 20 20:42:41 PDT 2004

Why are my IPI's stuck? They never used to be....

This box has been tracking RELENG_5 and was running fine
until about the end of August.

Now I get constant panics, even during a fsck when booted into
single user mode! The situation seems to have become worse :(

Its a Dell PowerEdge 6100/200 quad Pentium-Pro 200MHz with 512MB RAM.

I have tried both ULE and 4BSD schedulers. GENERIC has been panicing
for the last 4 weeks.

It was suggested I try infinite waiting in the ipi wait loop, but
that didn't work.

I tried s/panic/printf/ and this seemed to work... for a while.
Once, it printed 3 "Previous IPI is stuck" messages at various
times it was doing a buildworld, and eventually finished!
But the box will eventually crash, in different ways, with this

This box is not ready to be recycled yet, but is unable to run
the latest BETA5.

Can someone explain why an IPI might get stuck?



ps. I have posted twice previously with dmesg and other output.
If you want me to repeat, please ask.

More information about the freebsd-current mailing list