SMP problems with -CURRENT? (and BETA5)

David D.W. Downey david.downey at gmail.com
Mon Sep 20 15:46:11 PDT 2004


On Mon, 20 Sep 2004 17:52:25 -0400, Adam K Kirchhoff <adamk at voicenet.com> wrote:
> 
> 
> Adam K Kirchhoff wrote:
> 
> > Oliver Brandmueller wrote:
> >
> >> Hi again.
> >>
> >> On Mon, Sep 20, 2004 at 03:36:03PM +0200, Oliver Brandmueller wrote:
> 
> Well, booting with HTT disabled still doesn't work for me, which is
> making me think this isn't SMP related anymore...  My boot stalls with:
> 
> acpi_cpu: throttling enabled, 8 steps (100% to 12.5%), currently 100.0%
> ad0: 39083MB <Maxtor 5T040H4/TAH71DP0> [79408/16/63] at ata0-master UDMA100
> ad1: 117246MB <Maxtor 6Y120L0/YAR41VW0> [238216/16/63] at ata0-slave UDMA100
> ATAPI_RESET time = 40us
> ad2: 76345MB <MAXTOR 6L080J4/A93.0500> [155114/16/63] at ata1-master UDMA100
> acd0: DVDROM <Pioneer DVD-ROM ATAPIModel DVD-120/1.22> at ata1-slave UDMA66
> 
> Ideas?
> 


OK i have seen that before. it's the ACPI code doing CPU throttling.
(OK, obviously, hehe.)

What i don't understand and haven't solved is why it throttles so
early (for me) to the point that int he middle of a compile (which is
definitely NOT when you want it done <grin>) when the load on the
system, is definitely high enough to keep throttling from being
needed. It's almost like (and anyone working on the ACPI code PLEASE
do comment) whatever variable is responsible for the timing AND the
differential for check times is screwy.

That's all I have for now, meanwhile time for me to beat my head on
why the hell BETA5 is screwing up on an installworld with touch: file
not found for newvars.sh which exists in the directory it's trying TO
copy from.

-- 
David D.W. Downey


More information about the freebsd-current mailing list