panic: mutex Giant not owned at [...]/if_sl.c

Are Bryne are.bryne at
Thu Sep 16 02:22:53 PDT 2004


I am trying out FreeBSD 5.3 beta3 (using the installation GENERIC kernel) 
on an older Toshiba Satellite 4030CDT notebook with no built-in ethernet 
connection. Since the cardbus based RealTek card I've tried using doesn't 
work (perhaps more on that later), I've tried connecting it to another 
FreeBSD computer using slip.

This null-modem based slip connection worked flawlessly when the OS used 
to be FreeBSD 4.10. Now, however, I am getting a panic message:

panic: mutex Giant not owned at /usr/src/sys/net/if_sl.c:613
cpuid = 0
KDB: enter: panic
[thread 100082]
Stopped at      kdb_enter+0x2b: nop

This comes after sio0 has been detected, slattach has run and bpf has been 
attached to sl0. The sl0 connection is shown by the boot process, and the 
default gateway (to the slip gateway) has been set.

A trace (copied by hand):
db> tr
kdb_enter(c07f088b) at kdb_enter+0x2b
panic(c07efd14,c0800f22,c07f9eec,265,c1434000) at panic+0x127
_mtx_assert(c08b1900,1,c07f9eec,265) at _mtx_assert+0x5c
slstart(c1361e00) at slstart+0x32
sloutput(c1434000,c13ad100,c14443b0,c1440b58,c13ceb00) at sloutput+0x2ba
ip_output(c13ad100,0,c730fb18,0,0) at ip_output+0x6f0
udp_output [...]
udp_send [...]
sosend [...]
kern_sendit(c144e6e0,4,c730fccc,0,0) at kern_sendit+0xfa
sendit(c144e6e0,4,c730fccc,0,bfbfc427) at sendit+0x159
sendto(c144e6e0,c730fd14,6,16,202) at sendto+0x4d
syscall(2f,2f,2f,8111000,282f9b24) at syscall+0x213
Xint0x80_syscall() at Xint0x80_syscall+0x1f
--- syscall (133, FreeBSD ELF32, sendto), eip = 0x28282ca7, esp = 0xbfbfbcec, 
ebp = 0xbfbfbd18 ---

Is there anything else I can do to help iron this out?


Are Bryne
Communiqué DA                            Office:       +47 22 44 33 99
Postboks 9050 Grønland                   Mobile:        +47 900 22 009
NO-0133 Oslo                             URL:

More information about the freebsd-current mailing list