AMD64: with 3ware 9500 cards

Jean-Yves Avenard jean-yves at avenard.org
Tue Sep 14 18:29:38 PDT 2004


Dear all

It was recommended that I write in this list rather than in the usual 
freebsd newgroup.

With RELENG_5 (as of last Monday, that's 5.3-BETA4)

On our Opteron 2.4Ghz with 3ware 9500-8S card on a Tyan K8S-Pro board.

I've been trying to get the 3ware card to work with FreeBSD in native 
amd64 mode without much success.
It works perfectly with i386 target.

If I boot the amd64 FreeBSD 5.3-BETA4, the card is recognize but the 
system will hang just after the disk has been mounted.
Sep 12 00:30:25 server3 kernel: da0 at ahd0 bus 0 target 0 lun 0
Sep 12 00:30:25 server3 kernel: da0: <SEAGATE ST373307LW 0007> Fixed 
Direct Acce
ss SCSI-3 device
Sep 12 00:30:25 server3 kernel: da0: 320.000MB/s transfers (160.000MHz, 
offset 6
3, 16bit), Tagged Queueing Enabled
Sep 12 00:30:25 server3 kernel: da0: 70007MB (143374744 512 byte 
sectors: 255H 6
3S/T 8924C)
Sep 12 00:30:25 server3 kernel: da1 at twa0 bus 0 target 0 lun 0
Sep 12 00:30:25 server3 kernel: da1: <3ware Logical Disk 00 1.00> Fixed 
Direct A
ccess SCSI-0 device
Sep 12 00:30:25 server3 kernel: da1: 100.000MB/s transfers
Sep 12 00:30:25 server3 kernel: da1: 333735MB (683489280 512 byte 
sectors: 255H
63S/T 42545C)
Sep 12 00:30:25 server3 kernel: Mounting root from ufs:/dev/da0s1a

it will lock shortly after there.

Note that it works perfectly with i386 architecture.

I see in the CVS log that in version 1.7.2 of the 3ware driver that it 
is supposed to work with amd64 machines, unfortunately, it doesn't 
appear to be the case.

Any news, ideas? Have I missed something?

Regards
Jean-Yves


---
Jean-Yves Avenard
Hydrix Pty Ltd - Embedding the net
www.hydrix.com | fax +61 3 9572 2686 | phone +61 3 9572 0686



More information about the freebsd-current mailing list