ad0: TIMEOUT - READ_DMA retrying (2 retries left) LBA=207594611

Kevin Oberman oberman at es.net
Tue Sep 14 14:05:46 PDT 2004


> Date: Wed, 15 Sep 2004 02:14:27 +0900 (JST)
> From: FUJITA Kazutoshi <fujita at soum.co.jp>
> Sender: owner-freebsd-current at freebsd.org
> 
> Hi,
> 
> My 6.0-CURRENT box says, such as
> 
> ad0: TIMEOUT - READ_DMA retrying (2 retries left) LBA=207594611
> ad0: WARNING - READ_DMA no interrupt but good status
> 
> I replaced the ad0 with brand-new HDD, but I still got same messages.
> 
> The box has 3 HDDs(ad0,ad1,ad3) and DVD(acd0) drive, but the messages
> comes only from ad0.
> 
> What is happening?
> Cable problem or ATA controller problem?
> 
> 
> Regards,
> 
> Copyright (c) 1992-2004 The FreeBSD Project.
> Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
> 	The Regents of the University of California. All rights reserved.
> FreeBSD 6.0-CURRENT #4: Sun Sep 12 08:19:34 JST 2004
>     fujita at faithia:/usr/obj/usr/src/sys/FAITHIA
> WARNING: debug.mpsafenet forced to 0 as ipsec requires Giant
> WARNING: MPSAFE network stack disabled, expect reduced performance.
> Timecounter "i8254" frequency 1193182 Hz quality 0
> CPU: Intel(R) Pentium(R) 4 CPU 2.00GHz (2000.08-MHz 686-class CPU)
>   Origin = "GenuineIntel"  Id = 0xf24  Stepping = 4
>   Features=0x3febf9ff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH,DTS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM>
> real memory  = 536805376 (511 MB)
> avail memory = 515616768 (491 MB)
> npx0: [FAST]
> npx0: <math processor> on motherboard
> npx0: INT 16 interface
> acpi0: <AMIINT SiS645XX> on motherboard
> acpi0: Power Button (fixed)
> Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
> acpi_timer0: <24-bit timer at 3.579545MHz> port 0x808-0x80b on acpi0
> cpu0: <ACPI CPU (3 Cx states)> on acpi0
> acpi_button0: <Power Button> on acpi0
> pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
> pci0: <ACPI PCI bus> on pcib0
> agp0: <SiS 650 host to AGP bridge> mem 0xe0000000-0xe3ffffff at device 0.0 on pci0
> pcib1: <PCI-PCI bridge> at device 1.0 on pci0
> pci1: <PCI bus> on pcib1
> drm0: <ATI Radeon QW RV200 7500> port 0x9800-0x98ff mem 0xdfdf0000-0xdfdfffff,0xd0000000-0xd7ffffff at device 0.0 on pci1
> info: [drm] AGP at 0xe0000000 64MB
> info: [drm] Initialized radeon 1.11.0 20020828 on minor 0
> isab0: <PCI-ISA bridge> at device 2.0 on pci0
> isa0: <ISA bus> on isab0
> ohci0: <SiS 5571 USB controller> mem 0xdfffe000-0xdfffefff irq 11 at device 2.2 on pci0
> ohci0: [GIANT-LOCKED]
> usb0: OHCI version 1.0, legacy support
> usb0: <SiS 5571 USB controller> on ohci0
> usb0: USB revision 1.0
> uhub0: SiS OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
> uhub0: 3 ports with 3 removable, self powered
> ohci1: <SiS 5571 USB controller> mem 0xdffff000-0xdfffffff irq 5 at device 2.3 on pci0
> ohci1: [GIANT-LOCKED]
> usb1: OHCI version 1.0, legacy support
> usb1: <SiS 5571 USB controller> on ohci1
> usb1: USB revision 1.0
> uhub1: SiS OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
> uhub1: 3 ports with 3 removable, self powered
> atapci0: <SiS 961 UDMA100 controller> port 0xff00-0xff0f,0x376,0x170-0x177,0x3f6,0x1f0-0x1f7 at device 2.5 on pci0
> ata0: channel #0 on atapci0
> ata1: channel #1 on atapci0
> pcm0: <SiS 7012> port 0xd800-0xd87f,0xdc00-0xdcff irq 11 at device 2.7 on pci0
> pcm0: [GIANT-LOCKED]
> pcm0: <C-Media Electronics CMI9738 AC97 Codec>
> sis0: <SiS 900 10/100BaseTX> port 0xd400-0xd4ff mem 0xdfff9000-0xdfff9fff irq 5 at device 3.0 on pci0
> miibus0: <MII bus> on sis0
> rlphy0: <RTL8201L 10/100 media interface> on miibus0
> rlphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
> sis0: Ethernet address: 00:07:95:c0:de:e2
> sis0: [GIANT-LOCKED]
> fwohci0: <VIA Fire II (VT6306)> port 0xd000-0xd07f mem 0xdfff8800-0xdfff8fff irq 5 at device 9.0 on pci0
> fwohci0: [GIANT-LOCKED]
> fwohci0: OHCI version 1.0 (ROM=1)
> fwohci0: No. of Isochronous channels is 8.
> fwohci0: EUI64 00:40:26:01:06:04:21:f1
> fwohci0: Phy 1394a available S400, 3 ports.
> fwohci0: Link S400, max_rec 2048 bytes.
> firewire0: <IEEE1394(FireWire) bus> on fwohci0
> fwe0: <Ethernet over FireWire> on firewire0
> if_fwe0: Fake Ethernet address: 02:40:26:04:21:f1
> fwe0: Ethernet address: 02:40:26:04:21:f1
> fwip0: <IP over FireWire> on firewire0
> fwip0: Firewire address: 00:40:26:01:06:04:21:f1 @ 0xfffe00000000, S400, maxrec 2048
> sbp0: <SBP-2/SCSI over FireWire> on firewire0
> fwohci0: Initiate bus reset
> fwohci0: node_id=0xc800ffc0, gen=1, CYCLEMASTER mode
> firewire0: 1 nodes, maxhop <= 0, cable IRM = 0 (me)
> firewire0: bus manager 0 (me)
> em0: <Intel(R) PRO/1000 Network Connection, Version - 1.7.35> port 0xcc00-0xcc3f mem 0xdff80000-0xdff9ffff,0xdffa0000-0xdffbffff irq 11 at device 10.0 on pci0
> em0: [GIANT-LOCKED]
> em0: Ethernet address: 00:07:e9:00:f1:4d
> em0:  Speed:N/A  Duplex:N/A
> fxp0: <Intel 82550 Pro/100 Ethernet> port 0xc800-0xc83f mem 0xdff40000-0xdff5ffff,0xdfffd000-0xdfffdfff irq 5 at device 11.0 on pci0
> miibus1: <MII bus> on fxp0
> inphy0: <i82555 10/100 media interface> on miibus1
> inphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
> fxp0: Ethernet address: 00:02:b3:a6:83:2d
> fxp0: [GIANT-LOCKED]
> ohci2: <NEC uPD 9210 USB controller> mem 0xdfffa000-0xdfffafff irq 11 at device 12.0 on pci0
> ohci2: [GIANT-LOCKED]
> usb2: OHCI version 1.0
> usb2: <NEC uPD 9210 USB controller> on ohci2
> usb2: USB revision 1.0
> uhub2: NEC OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
> uhub2: 3 ports with 3 removable, self powered
> ohci3: <NEC uPD 9210 USB controller> mem 0xdfffb000-0xdfffbfff irq 5 at device 12.1 on pci0
> ohci3: [GIANT-LOCKED]
> usb3: OHCI version 1.0
> usb3: <NEC uPD 9210 USB controller> on ohci3
> usb3: USB revision 1.0
> uhub3: NEC OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
> uhub3: 2 ports with 2 removable, self powered
> ehci0: <NEC uPD 720100 USB 2.0 controller> mem 0xdfffcf00-0xdfffcfff irq 11 at device 12.2 on pci0
> ehci0: [GIANT-LOCKED]
> ehci_pci_attach: companion usb2
> ehci_pci_attach: companion usb3
> usb4: EHCI version 0.95
> usb4: companion controllers, 3 ports each: usb2 usb3
> usb4: <NEC uPD 720100 USB 2.0 controller> on ehci0
> usb4: USB revision 2.0
> uhub4: NEC EHCI root hub, class 9/0, rev 2.00/1.00, addr 1
> uhub4: 5 ports with 5 removable, self powered
> acpi_button1: <Sleep Button> on acpi0
> atkbdc0: <Keyboard controller (i8042)> port 0x64,0x60 irq 1 on acpi0
> atkbd0: <AT Keyboard> irq 1 on atkbdc0
> kbd0 at atkbd0
> atkbd0: [GIANT-LOCKED]
> psm0: <PS/2 Mouse> irq 12 on atkbdc0
> psm0: [GIANT-LOCKED]
> psm0: model IntelliMouse Explorer, device ID 4
> fdc0: <floppy drive controller> port 0x3f7,0x3f4-0x3f5,0x3f2-0x3f3 irq 6 drq 2 on acpi0
> fdc0: does not respond
> device_attach: fdc0 attach returned 6
> sio0 port 0x3f8-0x3ff irq 4 on acpi0
> sio0: type 16550A
> sio1 port 0x2f8-0x2ff irq 3 on acpi0
> sio1: type 16550A
> ppc0 port 0x778-0x77b,0x378-0x37f irq 7 drq 3 on acpi0
> ppc0: Generic chipset (ECP/PS2/NIBBLE) in COMPATIBLE mode
> ppc0: FIFO with 16/16/16 bytes threshold
> ppbus0: <Parallel port bus> on ppc0
> plip0: <PLIP network interface> on ppbus0
> lpt0: <Printer> on ppbus0
> lpt0: Interrupt-driven port
> ppi0: <Parallel I/O> on ppbus0
> fdc0: <floppy drive controller> port 0x3f7,0x3f4-0x3f5,0x3f2-0x3f3 irq 6 drq 2 on acpi0
> fdc0: does not respond
> device_attach: fdc0 attach returned 6
> orm0: <ISA Option ROMs> at iomem 0xcf000-0xd4fff,0xcd800-0xcefff,0xcc000-0xcd7ff,0xc0000-0xcbfff on isa0
> pmtimer0 on isa0
> sc0: <System console> at flags 0x100 on isa0
> sc0: VGA <16 virtual consoles, flags=0x300>
> vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
> Timecounter "TSC" frequency 2000083456 Hz quality 800
> Timecounters tick every 10.000 msec
> IPsec: Initialized Security Association Processing.
> pid 25: corrected slot count (0->1)
> ad0: 117800MB <HDS722512VLAT80/V33OA6EA> [239340/16/63] at ata0-master UDMA100
> ad1: 39266MB <IC35L040AVER07-0/ER4OA44A> [79780/16/63] at ata0-slave UDMA100
> ATAPI_RESET time = 70us
> acd0: DVDR <MATSHITADVD-RAM SW-9571/A109> at ata1-master UDMA66
> ad3: 176700MB <IC35L180AVV207-1/V26OA66A> [359010/16/63] at ata1-slave UDMA100
> cd0 at ata1 bus 0 target 0 lun 0
> cd0: <MATSHITA DVD-RAM SW-9571 A109> Removable CD-ROM SCSI-0 device 
> cd0: 66.000MB/s transfers
> cd0: cd present [2236704 x 2048 byte records]
> Mounting root from ufs:/dev/ad0s1a
> fxp0: Microcode loaded, int_delay: 1000 usec  bundle_max: 6
> fxp0: Microcode loaded, int_delay: 1000 usec  bundle_max: 6
> em0: Link is up 100 Mbps Full Duplex
> Accounting enabled
> ad0: TIMEOUT - READ_DMA retrying (2 retries left) LBA=93547835
> ad0: WARNING - READ_DMA no interrupt but good status
> ad0: TIMEOUT - READ_DMA retrying (2 retries left) LBA=222272571
> ad0: WARNING - READ_DMA no interrupt but good status
> ad0: TIMEOUT - READ_DMA retrying (2 retries left) LBA=226788623
> ad0: WARNING - READ_DMA no interrupt but good status
> ad0: TIMEOUT - READ_DMA retrying (2 retries left) LBA=229423379
> ad0: WARNING - READ_DMA no interrupt but good status
> ad0: TIMEOUT - WRITE_DMA retrying (2 retries left) LBA=46139535
> ad0: WARNING - WRITE_DMA no interrupt but good status
> ad0: TIMEOUT - READ_DMA retrying (2 retries left) LBA=54042843
> ad0: WARNING - READ_DMA no interrupt but good status
> ad0: TIMEOUT - READ_DMA retrying (2 retries left) LBA=64945143
> ad0: WARNING - READ_DMA no interrupt but good status
> ad0: TIMEOUT - READ_DMA retrying (2 retries left) LBA=110871947
> ad0: WARNING - READ_DMA no interrupt but good status
> ad0: TIMEOUT - READ_DMA retrying (2 retries left) LBA=198562163
> ad0: WARNING - READ_DMA no interrupt but good status
> ad0: TIMEOUT - READ_DMA retrying (2 retries left) LBA=203078227
> ad0: WARNING - READ_DMA no interrupt but good status
> ad0: TIMEOUT - WRITE_DMA retrying (2 retries left) LBA=16707487
> ad0: WARNING - WRITE_DMA no interrupt but good status
> ad0: TIMEOUT - READ_DMA retrying (2 retries left) LBA=186518883
> ad0: WARNING - READ_DMA no interrupt but good status
> ad0: TIMEOUT - READ_DMA retrying (2 retries left) LBA=197809407
> ad0: WARNING - READ_DMA no interrupt but good status
> ad0: TIMEOUT - READ_DMA retrying (2 retries left) LBA=207594611
> ad0: WARNING - READ_DMA no interrupt but good status
> ad0: TIMEOUT - READ_DMA retrying (2 retries left) LBA=171097435
> ad0: WARNING - READ_DMA no interrupt but good status

I recently reported the same thing. (Or, at least something very
similar.) 

A couple of questions...

1. Does the error show up when running in single-user mode?

2. Do you see any other errors? I get xl0: watchdog timeout messages and,
   if I don't configure xl0, the errors don't happen.

This is quite disturbing. I am running on an AMD K6-3 CPU in an ASUS P5A
board, so there is not much in common from a hardware perspective. The
only thing that catches my eye is that we are both running with
mpsafenet=0 due to the presence of IPsec. Just how this could cause this
problem, I have no idea, but it's about the only thing I see that links
our systems.
-- 
R. Kevin Oberman, Network Engineer
Energy Sciences Network (ESnet)
Ernest O. Lawrence Berkeley National Laboratory (Berkeley Lab)
E-mail: oberman at es.net			Phone: +1 510 486-8634


More information about the freebsd-current mailing list