device pcm

Mathew Kanner mat at cnd.mcgill.ca
Mon Sep 6 09:33:44 PDT 2004


On Sep 05, Derrick Edwards wrote:
> On Sunday 05 September 2004 03:31 pm, Mathew Kanner wrote:
> 
> Well guys still having probs with sound. I have tried all recommendtions.
> 
> This is the outpit of my /dev/sndstat
> 
> cat /dev/sndstat
> FreeBSD Audio Driver (newpcm)
> Installed devices:
> pcm0: <Intel ICH4 (82801DB)> at io 0xc000, 0xc400 irq 17 bufsz 16384 (1p/1r/0v 
> channels duplex default)
> 
> Keep in mind that I do have snd_driver loaded in /boot/loader.conf even 
> snd_ich for overkill
> 
> Output of loader.conf 
> nvidia_load="YES"
> hw.ata.atapi_dma="1"
> linux_load="YES"
> snd_driver_load="YES"
> snd_ich_load="YES"
> 
> Can anyone explain why i do not have a driver associated with card 
> in /dev/sndstat. Also, every one out of 50 reboots, I will get sound for 2 
> seconds then it dies.
> 
> This is my pciconfig
> 
> pcm0 at pci0:31:5: class=0x040100 card=0x4941434d chip=0x24c58086 rev=0x02 
> hdr=0x00
>     vendor   = 'Intel Corporation'
>     device   = '82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller'
>     class    = multimedia
>     subclass = audio

	I don't know the answer but I would recommend doing the
following.  

1/ Removing sound from your kernel.
2/ Disable ACPI and NVIDIA

if 2 works
	renable but use host provided AGP.

	Let me know what happens
	Thanks,
	--Mat

-- 
	(on the United States) Living next to you is in some ways
	like sleeping with an elephant. No matter how friendly and
	eventempered the beast, one is affected by every twitch and
	grunt.
			- Pierre Elliott Trudeau


More information about the freebsd-current mailing list