disklabel: Geom not found

Niki Denev nike_d at cytexbg.com
Sun Sep 5 18:26:35 PDT 2004

so... everyting started when i bought that damn USB Floppy, and tried to 
make a bootable diskette in the middle of the night,
and of course i've mistyped fdisk/disklabel 'da0' with 'ad0',
wiping out the disklabel.
This happened on my laptop running -current.
Hopefully i had a machine with 5.2-release next to me,
so i removed the laptop HDD and attached it to it.
Thanks to scan_ffs i was able to restore the disklabel,
but i've made a typo entering the size of the 'c'(raw) partition.
Disklabel complained that the c part. doesn't cover the whole device,
but in the hurry i forgot about this, 
and attached the disk again to the laptop.
It booted normaly and everyting was ok,
and then i decided to fix the c partition size. 
I dumped the disklabel in text file, edited the c part to 
the proper size and when i tried to write it back,
disklabel printed out this message :
"disklabel: Geom not found"
and didn't update the label.
This happened on the laptop running -current,
so i suppose this has something to do with the geom-ification in current :)
but i don't have idea how to fix it?
any suggestions?

Thanks in advance,

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: not available
Url : http://lists.freebsd.org/pipermail/freebsd-current/attachments/20040906/7b4f74ce/attachment.bin

More information about the freebsd-current mailing list