Latest MFCs break boot on amd64 notebook.

Ian Dowse iedowse at
Fri Sep 3 20:05:17 PDT 2004

In message <413910FD.2090905 at>, Scott Long writes:
>Andrew Lankford wrote:
>> The latest MFCs (the eagerly awaited boot-time module
>>  loading functionality on amd64) compiled ok, but my
>> machine freezes and then powers down shortly after
>> "boot" from the loader.  I would try to give you all
>> more details, but my old working kernel seems to be
>> lost, and so I'm pretty much down for the count.
>> Any other amd64 users out there tried rebuilding
>> their kernels in the past few hours?
>> Andrew Lankford
>Were you actually trying to load any modules from the loader,
>or was it just loading in the kernel?  Also, have you tried
>running a 6-CURRENT system for comparison?

Any further information you can provide would be appreciated.  For
example, do any kernel messages appear before the freeze? What does
"lsmod" from the loader output, and I presume you've tried booting
kernel.old ("unload", "load /boot/kernel.old/kernel", "boot")?

You could also try booting with the old loader by interrupting the
boot process by pressing a key immediately after the first of the
|/-\ sequence appears.  You should get a prompt like:

	>> FreeBSD/i386 BOOT
	Default: 0:ad(0,a)/boot/loader



and see if that allows you to boot.


More information about the freebsd-current mailing list