No keyboard with Gnome and (and gnome loaded behind KDE)

Esaltato esaltato at
Fri Sep 3 02:53:57 PDT 2004

I got a problem with GNOME since switching to xorg. On KDE everything is 
fine, but on Gnome 2.6 (all my system has been portupgraded yesterday) 
my keystrokes are blocked; as I type the text cursor stops blinking and 
nothing gets written. If I press ctrl, shift and some letters a lot of 
times it may happen that I can write sometimes, but only as long as I 
hold shift down and I don't change the writing focus. It seems like if 
my keys command are getting intercepted. This only happens as root.
I want to point out that I've been throughly searching for solutions, 
and that not a solution proposed on the net has solved this.
It may be related to the problem of this message popping up on Gnome 
(which I don't have, let's clarify it now, more on this later):

:::::::start message
Error activating XKB configuration.
Probably internal X server problem.

X server version data:
The X.Org Foundation

If you report this situation as a bug, please include:
- The result of xprop -root | grep XKB
- The result of gconftool-2 -R /desktop/gnome/peripherals/keyboard/xkb
:::::::end message

These are the results:

localhost# xprop -root | grep XKB
_XKB_RULES_NAMES(STRING) = "xorg", "logiik", "it", "basic", ""
localhost# gconftool-2 -R /desktop/gnome/peripherals/keyboard/xkb
 layouts = [it]
 model = logiik
 overrideSettings = false
 options = []

No help in changing the keyboard values...

People report that this error message usually comes on start after the 
xorg update, but I _did not_ have this problem. I only get that pop up 
message (twice) if I go to the gnome keyboard panel and remove my 
italian keymap (I tried switching to no keymap and US).
I followed the UPDATING hints related to gnome and xorg, so I rebuilt 
the 2 needed libraries x11-toolkits/libwnck and x11/libxklavier.
I _haven't_ got the line

Option "XkbRules" "xfree86"

in my xorg file, which I let xorg itself build, and then I modified 
accordingly to my needs. I tried everything, and everything seems OK:
Section "InputDevice"

    Identifier    "Keyboard1"
    Driver    "Keyboard"

    Option "AutoRepeat" "500 30"

    Option "XkbRules"    "xorg"
    Option "XkbModel"    "logiik"
    Option "XkbLayout"    "it"

    InputDevice "Keyboard1" "CoreKeyboard"

Oh, and I upgraded like the HEADSUP said. I use kdm now, but I used xdm 
when the problem surfaced.

Any idea? I seem the only one with this problem. As for now, I'm 
sticking with KDE, but I need/want GNOME.
Oh, just another thing that may be related, but I don't think is, but 
anyway is annoying: when I go to the desktop properties and hide my 
icons from the KDE desktop my GNOME desktop comes along, with all the 
icons (just some of them are blank, since gnome is not completely 
loaded) (and yes, keyboard works). Moreover the GNOME desktop picture 
comes up when I turn off my PC: why? Is a part of GNOME being loaded 
aside with kde/kdm?

More information about the freebsd-current mailing list