mysql on recent RELENG_5

Oliver Brandmueller ob at e-Gitt.NET
Thu Sep 2 18:34:42 PDT 2004


Hi,

I see a little problem with either mysql-server 3.23 or 4.1.3 on a 
RELENG_5 as of about 12 hours ago:

mysql runs fine so far, but as soon as I do not connect by socket, but 
by network on localhost (127.0.0.1) the mysqld dies by sig11 (and is the 
restarted automatically by the wrapper).

I tried ULE and 4BSD, I tried a mysql 3.23 from package. I tried 
compiling 3.23 and 4.1.3 (did not try 4.1.4 which just arrived at the 
ports a few hours ago) "just plain", with BUILD_OPTIMIZED, with 
WITH_LINUXTHREADS defined and saw now difference. I also changed 
libpthread to libc_r by libmap.conf and had no difference.

I'm currently a bit under pressure to get things running (I need MySQL 
for Nagios, this means I could live without it), so I just want to know 
if anyone else can reproduce this behaviour? If you have a similar setup 
it's enough to just telnet to port 3306 on localhost, if you see mysqld 
closing the connection at once and see in the mysql log that the server 
has been restarted because of a sig11 then you see the same thing. Well, 
if everything works for you I'd be interested in working out the 
differences of our configs.

Thanx, Oliver

-- 
| Oliver Brandmueller | Offenbacher Str. 1  | Germany       D-14197 Berlin |
| Fon +49-172-3130856 | Fax +49-172-3145027 | WWW:   http://the.addict.de/ |
|               Ich bin das Internet. Sowahr ich Gott helfe.               |
| Eine gewerbliche Nutzung aller enthaltenen Adressen ist nicht gestattet! |


More information about the freebsd-current mailing list