broken APM on IBM-T30 with 6.0-CURRENT

Anders Odberg anders.odberg at
Thu Oct 28 11:29:31 PDT 2004

[Gleb Smirnoff]

|  |   I recently CVSup'd and noticed I can no longer APM suspend properly.
|  |   The system just freezes while going into suspend.  I don't know if
|  |   I'm getting a panic or not.  There's no trace or anything.  Anyone
|  |   got any ideas?  The problem occurs in multiuser and singleuser mode
|  |   and regardless of whether I'm in X or not.  I'm not evern sure where
|  |   to begin looking. 
|   can you try out attached hack?

I can confirm that the patch you attached solved my long-standing problems
with APM suspend/resume on a Thinkpad T40 and A21e when applied to todays
RELENG_5 cvsup. All versions of RELENG_5 I've tried since the end of August
have caused my Thinkpads to freeze either when suspending or when resuming.


  Anders Odberg, <anders.odberg at>
  Center for Information Technology Services
  University of Oslo, Norway

More information about the freebsd-current mailing list