20% packet loss with re0 in gigE mode vs. 0% in 100BT

Robert Watson rwatson at freebsd.org
Mon Oct 11 12:33:16 PDT 2004


On Mon, 11 Oct 2004, Sean McNeil wrote:

> > Assuming you're not filling the send buffer, it would definitely suggest a
> > driver, configuration, or hardware bug.  There have recently been a number
> > of changes to the if_re driver to fix support for jumbo frames, etc.  It
> > would be interesting to know whether backing out to earlier revisions of
> > the if_re driver affect the problem you're seeing.  In particular,
> > ifre.c:1.35 was the jumbo frame change, so 1.34 would be interesting, and
> > 1.31 is before some other related changes.  Likewise, you could try
> > backing out to before locking was introduced by setting debug.mpsafenet=0
> > in loader.conf and then backing out to if_re.c:1.29.  I might be generally
> > useful to try setting debug.mpsafenet=0 with the current driver to
> > eliminate that as a possible concern.
> 
> These are good suggestions as well, but I have heard from another user
> that has seen this kind of thing over all of these versions.  It is less
> likely then that the jumbo or locking changes caused the issue. 

Have you tried 4.x to see if the same problem occurs there?

Have you tried the normal juggling of ACPI, APIC, and other configuration
variables?  It sounds like things work fine at minimal bandwidth rates, so
that probably rules out interrupt problems and the like, but I figured it
was worth asking.

I assume you've probably looked at substituting the switch, forcing
auto-negotiation to 1gb, etc?

Robert N M Watson             FreeBSD Core Team, TrustedBSD Projects
robert at fledge.watson.org      Principal Research Scientist, McAfee Research



More information about the freebsd-current mailing list