Library bumps and gcc/g++ versions

Andy Fawcett andy at athame.co.uk
Sun Oct 10 23:34:04 PDT 2004


hi,

Recently we saw library bumps for various shared libraries because of 
changes since 4.x

Would it make sense to also bump the c++ related libraries when we take 
a gcc that has an incompatible C++ ABI.

Currently I have a couple of commercial closed-source applications that 
are built against 5.2.1, and won't be rebuilt in the (near) future for 
5.3.

Bumping the c++ library versions would allow the 5.2.1 libstdc++ library 
(and related libs) to be included as a compat52x-type library, allowing 
such applications to continue working.

Andy

-- 
Andy Fawcett                                     | andy at athame.co.uk
                                                 | tap at kde.org
"In an open world without walls and fences,      | tap at lspace.org
  we wouldn't need Windows and Gates."  -- anon  | tap at fruitsalad.org


More information about the freebsd-current mailing list