re0 failures at 1Gb vs. 100Mb

Sean McNeil sean at
Sat Oct 9 14:10:06 PDT 2004

On Sat, 2004-10-09 at 13:28, Sean McNeil wrote:
> On Sat, 2004-10-09 at 13:09, Daniel Eriksson wrote:
> > Sean McNeil wrote:
> > 
> > > I have a strange problem that I have with my network that is 
> > > related to the output rate of my re0.
> > 
> > I have a similar problem, but I haven't reported it before because I wasn't
> > sure it was the fault of the NIC.
> > 
> > No matter what I do, single connection output rate (TCP) from the RealTek is
> > erratic and the average is well below expectations when it operates at
> > 1Gbit. If I force it to 100Mbit (either through ifconfig, or by placing a
> > cheap 100Mbit switch in between it and GigE switch) the average speed goes
> > up quite a bit due to a much more stable and consistently high single
> > connection throughput.
> > 
> > I have not done much testing of this, but I thought it would be useful to
> > know that others are having issues too.
> I was just about to look into polling mode. Have you tried it?  Does it
> make a difference?

I just read up on this and tried it.  It is wouldn't help in my case
anyway as polling is for read performance.  Tried it anyway and indeed
it made no difference.

One additional thing I noticed is that from my observations it might be
a problem with flushing the dma buffers before the data is transmitted.
Just a WAG from some of the visuals I'm seeing in my tests.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: This is a digitally signed message part
Url :

More information about the freebsd-current mailing list