SiS 962/963 support?

Rick Morris rmorris at
Tue Oct 5 20:48:12 PDT 2004

Søren Schmidt wrote:

> Richard Morris wrote:
>> Søren Schmidt wrote:
>>> Rick Morris wrote:
>>>> None of the betas for 5.3 will boot on my systems with the SiS 962 IDE
>>>> controllers. I notice that they are not listed in the Handbook 
>>>> under supported
>>>> hardware. Can anyone tell me whether there are plans to support this
>>>> chipset, and if so, what the status is? I've found various posts in 
>>>> -bugs and other lists mentioning this chipset in the past, but 
>>>> there seems to be no discussion of this for 5.x. All of our 
>>>> deployed units with 5.2.1 boot fine with this chipset, but 5.3 
>>>> freezes on the ado: and acdo: messages in boot. Even CTRL-ALT-DEL 
>>>> doesn't work, requiring a manual shutdown.
>>>> If anyone has worked on this problem, my company would be very 
>>>> interested in talking with you.
>>> The SiS southbridges should be supported, at least the two systems I 
>>> have here in the lab works just dandy.
>>> Could you mail me the output of a verbose boot from 5.2.1 and as far 
>>> as it gets on 5.3beta7 please ?
>> I have attached the verbose output from 5.2.1, and here is how the 
>> output from 5.3beta7 ends (curing CD boot from 
>> 5.3-BETA7-i386-bootonly.iso):
>> ata0-master: pio=0x0c wdma=0x22 udma=0x45 cable=80pin
>> ata0-master: setting PIO4 on SiS 5513 chip
>> ata0-master: setting UDMA100 on SiS 5513 chip
>> GEOM: create disk ad0 dp=0xc2cb4560
>> ad0: <WDC WD400BB-22HEA0/13.03G13> ATA-6 disk at ata0-master
>> ad0: 38166MB (78165360 sectors), 77545 C, 16 H, 63 S, 512 B
>> ad0: 16 secs/int, 1 depth queue, UDMA100
>> GEOM: new disk ad0
>> ar: FreeBSD check1 failed
>> ata1-master: pio=0x0c wdma=0x22 udma=0x42 cable=40pin
>> ata1-master: setting PIO4 on SiS 5513 chip
>> ata0-master: setting UDMA33 on SiS 5513 chip
>> [0] f:80 typ:165 s(CHS):0/1/1 e(CHS):1023/254/63 s:63 l:78156162
>> [1] f:00 typ:0 s(CHS):0/0/0 e(CHS):0/0/0 s:0 l:0
>> [2] f:00 typ:0 s(CHS):0/0/0 e(CHS):0/0/0 s:0 l:0
>> [3] f:00 typ:0 s(CHS):0/0/0 e(CHS):0/0/0 s:0 l:0
>> GEOM: Configure ad0s1, start 32256 length 40015954944 end 40015987199
>> GEOM: Configure ad0s1a, start 0 length 268435456 end 268435455
>> GEOM: Configure ad0s1b, start 268435456 length 476880896 end 745316351
>> GEOM: Configure ad0s1c, start 0 length 40015954944 end 40015954943
>> GEOM: Configure ad0s1d, start 745316352 length 3221225472 end 3966541823
>> GEOM: Configure ad0s1e, start 3966541824 length 4294967296 end 
>> 8261509119
>> GEOM: Configure ad0s1f, start 8261509120 length 8589934592 end 
>> 16851443711
>> GEOM: Configure ad0s1g, start 16851443712 length 23164511232 end 
>> 40015954943
>> acd0: <HL-DT-ST GCE-8525B/1.03> CDRW drive at ata1 as master
>> acd0: read 6890KB/s (8957KB/s) write 8957KB/s (8957KB/s), 2048KB 
>> buffer, UDMA 33
>> acd0: Reads: CDR, CDRW, CDDA stream, packet
>> acd0: Writes: CDR, CDRW, test write, burnproof
>> acd0: Audio: play, 255 volume levels
>> acd0: Mechanism: ejectable tray, unlocked
>> acd0: Medium: CD-R 120mm data disc
>> (At this point, the system simply freezes. How would I be able to 
>> grab *all* the output from this? Is there an option on this boot CD 
>> to enable a serial cable connection?)
> Uhm, I miss the vital parts though, but I think I can glean most of 
> what I wanted, could you supply me with the output of pciconf -l ? 
> (that can be from the 5.2.1 kernel)..

agp0 at pci0:0:0:  class=0x060000 card=0x06511039 chip=0x06511039 rev=0x02 
pcib1 at pci0:1:0: class=0x060400 card=0x00000000 chip=0x00011039 rev=0x00 
isab0 at pci0:2:0: class=0x060100 card=0x00000000 chip=0x00081039 rev=0x14 
fwohci0 at pci0:2:3:       class=0x0c0010 card=0x13941039 chip=0x70071039 
rev=0x00 hdr=0x00
atapci0 at pci0:2:5:       class=0x01018a card=0x55131039 chip=0x55131039 
rev=0x00 hdr=0x00
none0 at pci0:2:7: class=0x040100 card=0xf6141565 chip=0x70121039 rev=0xa0 
ohci0 at pci0:3:0: class=0x0c0310 card=0x33021565 chip=0x70011039 rev=0x0f 
ohci1 at pci0:3:1: class=0x0c0310 card=0x33021565 chip=0x70011039 rev=0x0f 
ohci2 at pci0:3:2: class=0x0c0310 card=0x33021565 chip=0x70011039 rev=0x0f 
none1 at pci0:3:3: class=0x0c0320 card=0x33021565 chip=0x70021039 rev=0x00 
sis0 at pci0:4:0:  class=0x020000 card=0x09001039 chip=0x09001039 rev=0x90 
none2 at pci1:0:0: class=0x030000 card=0x63251039 chip=0x63251039 rev=0x00 

>> (At this point, the system simply freezes. How would I be able to 
>> grab *all* the output from this? Is there an option on this boot CD 
>> to enable a serial cable connection?
> Yeah use a serial console, its in the handbook IIRC...
>>> Have you tried disabling ACPI and/or APIC ? Both the SiS systems 
>>> here have had very diffrent success with both of those during times...
>> Yes, I have tried disabling both of these in the BIOS without 
>> success. The system in question is one of those small-form-factor 
>> cubes from iDeq, with the SiS 651 B/962 chipset.
> No no, not in the BIOS, that wont change anything, you should boot 
> without them (you can choose so in the little menu before the kernel 
> boots)..

I also chose the non-ACPI boot from the menu, and it made no difference.

> Also from the old dmesg I see you have atapicam in there, please 
> remove that so we can get that out of the equation for the hang...

OK, coming up soon...

Meanwhile, I will get you the full output from the serial console 
connection, as soon as I can pick up a serial cable (tomorrow). Please 
let me know if there is anything else I can do to provide useful 

Best regards,

Rick Morris
Application Developer
MOS Imaging Systems
rmorris at
305-779-1247 Direct Line

More information about the freebsd-current mailing list