switching cardbus card hangs in 6-CURRENT?

M. Warner Losh imp at bsdimp.com
Tue Oct 5 20:28:59 PDT 2004

In message: <08d601c4a954$242380b0$f700000a at ape>
            "Markie" <mark.cullen at dsl.pipex.com> writes:
: I installed via a 5.3-BETA5 CD and I was able to switch network cards, a
: D-Link  DWL-G650 and an Intel... can't remember, fxp0 driver; both are
: cardbus cards anyway. Now I have updated to 6.0-CURRENT (a few days ago) I
: have noticed I can no longer take the card out. If I do, the system appears
: appears to hang while running X.
: I just now tried from the console and it's actually a panic.
: Fatal trap 12: page fault while in kernel mode
: cpuid = 0; apic id =00
: fault virtual address 0x3c
: fault code = supervisor read, page not present
: instruction pointer = 0x8:0xc056a2ce
: stack pointer = 0x10:0xc7c86b90
: frame pointer = 0x10:0xc7c86bac
: code segment = base 0x0, limit 0xfffff, type 0x1b
:  = DPL 0, pres 1, def32 1, gran 1
: processor eflags = interrupt enabled, resume, IOPL = 0
: current process = 40 (cbb0)
: trap number = 12
: panic: page fault
: cpuid = 0
: Uptime: 3m53s
: You'll probably have to excuse the formatting as that was hand typed.
: Curiously, it doesn't come up with the press any key to reboot or anything
: and just seems to be stuck there. I don't think that's normal? Perhaps I
: should send this to the current list too...
: Any advice?

Add DDB into the kernel and give me a traceback.

It works for me with the three or four cards I've tried.


More information about the freebsd-current mailing list