ATA problems

Søren Schmidt sos at
Mon Oct 4 05:40:10 PDT 2004

Andox wrote:
> Thanks, Søren for looking into this problem. I have had it since 5.2.1 
> release.
> With your latest fix committed to RELENG_5 my computer is more stable 
> but it’s
> not 100% yet. I still get lookups then copying files between two disks.
> My test is to copy some DVDs of total 22GB from one disk to another and 
> after
> some minutes the computer crashes with no error message in 
> /var/log/messages.

Hmm, have you tried an uptodate -current kernel lately ?

> Also then mounting disks, I get:
> adX: TIMEOUT - READ_DMA retrying (2 retries left) LBA=XXXXXXXXX
> Usually I get one of these messages for each 'mount'.
> These messages seem harmless but still they show up.
> I am using ATAIDLE (/usr/ports/sysutils/ataidle) with the mounted disks 
> if this matters…

Hmm, you will get a timeout on the disks if they spun down since they'll 
have to get wacked to come back to life.
At any rate the number of problem reports on using ataidle in this setup 
is increasing so my standpoint of it being a bad idea and keeping it out 
of ATA as such seems to hold ;)

PLEASE try to run without ataidle for a while and see if behavior 



More information about the freebsd-current mailing list