5.3-BETA6 boot-time hang

Søren Schmidt sos at DeepCore.dk
Mon Oct 4 00:48:19 PDT 2004

Bruce A. Mah wrote:
> I just updated a RELENG_5 system from sometime around 5.3-BETA4 (17
> September) to very late 5.3-BETA6 (just before the 5.3-BETA7 version
> number bump) and it's now hanging after probing its DVD drive.  This
> problem sounds vaguely like what was described in the thread "ATTN
> Soren: BETA3 still hangs on ATAPI DVD Detection during boot":
> http://lists.freebsd.org/pipermail/freebsd-current/2004-September/036543.html
> The interesting thing is that my system appeared to be working just
> fine with the BETA4 code.
> I've appended verbose boot output from BETA4, as well as the lines
> that I think were relevant from a BETA6 boot, at least up to the point
> where it hung.  The latter output is hand-copied.  The system isn't
> totally wedged because I can page back through the console's
> scrollback buffer, but the kernel just doesn't seem to finish probing
> and attaching devices.
> I tried disabling ATAPI DMA as Soren suggested in the thread above by
> setting hw.ata.atapi_dma=0 from the loader; this seemed to have no
> effect.
> I tried backing out the ata driver updates from 30 September to see if
> that might help matters, but it didn't seem to help.  Neither did
> booting the kernel from the 5.3-BETA6 bootonly iso image; that hangs
> in exactly the same way.
> At this point I'm kind of flailing around at random.  At first I
> had suspected the ata(4) driver but the evidence I've seen so far
> doesn't really point in that direction.
> Any ideas?  Thanks for any suggestions!

> (probe0:ata0:0:0:0): error 22
> (probe0:ata0:0:0:0): Unretryable Error

Try ripping out atapicam, see if that changes anything....



More information about the freebsd-current mailing list