5.3-BETA5 AMD64 Python problems

Matt Hamilton matth at netsight.co.uk
Sun Oct 3 00:00:49 PDT 2004

Hi All,
   We have just bought ourselves an AMD64 machine (HP DL145) and I have 
put 5.3-BETA5 on it.  This is our first foray into 5.x, so far we have 
kept all our servers on 4.x.  The server is meant to be a Zope server, 
but I am having trouble with python.

Python 2.3.4 as built from ports cannot pass its own unit tests on this 
platform, specifically it fails test_re.py in about the 4th test 
(something to do with catching infinite recursion on a regular 
expression).  The test just core dumps (as does trying to start Zope). 
I thought this was the well known 'FreeBSD has a tiny pthread stack 
size' issue.  This is fixed in recent pythons (and the ports) by calling 
pthread_setstacksize to increase the stack to 1MB.

I've tried this on 5.3-BETA5/AMD64, but to no avail.  If I compile 
python *without* thread support, then the unit test passes.  So I think 
it is related to threads.  I've not managed to keep my finger on the 
-current development pulse, but wasn't threads re-written in 5.x?  Or 
was it just the scheduler (I am using whichever scheduler 5.3-BETA5 uses 
by default).

I've even tried raising the stack size to 64MB in python, but still it 
core dumps.

Anyone else using python on 5.x?  Can you test it passes its regex unit 
tests?  As currently I'm unsure if the problem is related to:

1) AMD64 support
2) 5.x's new threads and/or scheduler
3) something else :)

I'm pretty sure I've heard of people running Zope on 5.1 (I'm guessing 
it was i386) so I'm thinking it is a 64-bit issue.


Matt Hamilton                                       matth at netsight.co.uk
Netsight Internet Solutions, Ltd.        Business Vision on the Internet
http://www.netsight.co.uk                             +44 (0)117 9090901
Web Design | Zope/Plone Development & Consulting | Co-location | Hosting

More information about the freebsd-current mailing list