bsdtar doesn't detect end of tape

Tim Kientzle tim at
Sat Oct 2 14:34:29 PDT 2004

Oliver Lehmann wrote:
> Tim Kientzle wrote:
>>Ergh.  I haven't managed to reproduce
>>this here yet; I'll keep trying.
> ok, I checked out the latest version of libarchive and tar (CURRENT) and
> compiled them. Still the same problem - I can tar more than the tape can
> hold (I tared all files of a filelist for a dds3 tape on a dds2 tape).
> I got no error.

I've tried it against a floppy and the write
does fail, though there are a few ugly points
in there.

Hmm...  I wonder if the tape device driver you're
using doesn't consistently return an error for
a write past end-of-media?  I did find a couple
of places where failed writes were getting ignored,
but if the device keeps returning failure, then
bsdtar does eventually get the hint.

I'll have a revised patch for you to try soon.
(Let me know when you get back from vacation.)

Thanks for your help,


More information about the freebsd-current mailing list