Jason King jasonking at sbcglobal.net
Thu May 13 21:17:29 PDT 2004

I'm having some problems with -CURRENT locking up, I'm hoping maybe 
someone will have some suggestions.


(This is both on 5.2.1-CURRENT as well as booting off the 5.2.1-RELEASE 

During normal boot, kernel freezes before it even starts init.  
Ctrl-Alt-Delete does not work, power button must be used to reboot.

boot -v reveals 'Interrupt storm on "dc0"; throttling interrupt 
source'.  Thinking it might be a bad network card (though it works fine 
in XP and worked fine when I had 5.1-RELEASE installed), I removed the 
card, and I got the same error, just on a different device (pcm0).

Booting into safe mode works without incident

Booting with ACPI disabled works, however it is *significantly* slower 
than booting into safe mode (>5 minutes from boot->init started vs. 
~1min in safe mode)

X 4.3.0 locks up system (cannot ctrl-alt-delete, ctrl-alt-backspace, or 
ctrl-alt-esc) when invoked with anything but a depth of 8 (might be 
unrelated, but thought it worth mentioning)

Building a new kernel with ddb installed and with debugging symbols, 
same symptoms appear.  Ctrl-Alt-Esc does not work when the system 
freezes, though if i boot into safe mode, it works just fine and drops 
me to the debugger.

I at one point had 5.1-RELEASE installed on the same system (absolutely 
no hardware changes), without any issues.

    AMD Athlon XP 2400 (NOT overclocked or tweaked in any way), 512MB ram
    Gigabyte 7-N400-L1 (nForce 2 chipset)
    ATI Radeon 7500 gfx card
    Seagate ST3120026A 120MB ATA/100 HD (on primary ide channel)
    Plextor PX-W1210A CDRW (on secondary ide channel)
    Lite-On 10/100 PCI Ethernet

Any pointers or additional suggestions to try to narrow down the cause 
of the lockups would be appreciated

More information about the freebsd-current mailing list