fetch hangs on 6/24/04 current build

Jon Noack noackjr at alumni.rice.edu
Thu Jun 24 23:00:49 PDT 2004

On 06/24/04 23:09, Conrad J. Sabatier wrote:
> I just upgraded both of my machines today, and since then, I'm getting
> lots of hangs during port fetches.  I don't know if this is just a
> local problem, or a problem with my ISP's routing, or what.
> Any recommendations on how to diagnose what's going on here?

This happened to me a week or so ago -- the workaround for me was to not 
set the FTP_PROXY and HTTP_PROXY environment variables.  When I tried to 
use a proxy, it hung; without, everything worked fine.  By the way, wget 
worked fine even with the proxy, so it was just fetch that was 
misbehaving.  Note that I was just starting to define those variables 
when I noticed the problem; I can't say from experience that fetch ever 
worked properly with a proxy...

If you're not using a proxy, there was a recent commit to fetch that 
could have broken things for you:

This just changed the behavior of -S (checking the size); do you see a 
"size unknown" error message before the hang?  In any case, you could 
try to back out rev. 1.68 and recompile fetch.

There's a lot going on in networking right now.  ipf 3.4.35 landed 
recently -- this could be related to that.  As I don't use ipf I'm not 
sure of a workaround.

Gross speculation at this point:
Something else you could try is disabling SACK (it just landed a couple 
days ago).  To do that just 'sysctl net.inet.tcp.sack.enable=0' and try 
again.  However, the SACK implementation came from Yahoo.  I would bet 
it's been tested fairly well and doubt that it is to blame...

I'm sure someone else more knowledgeable can provide better answers. 
These are just my (hopefully not humorously) ignorant guesses.



More information about the freebsd-current mailing list