new motherboard - fsck_ufs died with signal 8

Gordon Bergling gbergling at
Mon Jun 21 19:33:04 GMT 2004


On Mon Jun 21, 2004 at 04:55PM +0200, Gordon Bergling wrote:
> today I am getting my hands on a new motherboard. I upgraded my system
> from VIA KT133A based Motherboard (Athlon 1GHz) to a KT266A based one
> with an Athlon XP 1600+ (DDR Ram). It seems that the hardware is working proberly.
> If I try to boot my FreeBSD installation the kernel boots up and after
> init was started I am gettings signal 8 at the following processes.
> (fsck_ufs, ...). I tried to boot without ACPI but it doesn't change
> anything.
> FreeBSD will only boot with "FreeBSD Safe-Mode" choosen from the start
> menu.
> Can anyone tell me what "FreeBSD Safe-Mode" means?
> My kernel-config is only a little bit different from GENERIC.
> Should I change something in my kernel config?
> Should I "make world" again?

It tried many times to get in complete build for an GENERIC based kernel
config, but I didn't get _one_ successfully build. Every build breaks on
a different position of the build process. Mostly asm-erros or gcc core
dumps. The strange thing is that the build of GENERIC runs successful.

This system seemed to be stable, but after an hour or two I had two
different panics.

The first one was:

| stray irq7
| stray irq7
| stray irq7
| stray irq7
| stray irq 7's: not logging anymore
| TPTE at 0xbfc203d4  IS ZERO @ VA 080f5000
| panic: bad pte
| cpuid = 0;
| syncing disks, buffers remaining...
| kernel trap 12 with interrupts disabled
| Fatal trap 12: page fault while in kernel mode
| cpuid = 0; apic id = 00
| fault virtual address   = 0x24
| fault code              = supervisor read, page not present
| instruction pointer     = 0x8:0xc0566ade
| stack pointer           = 0x10:0xcdafec44
| frame pointer           = 0x10:0xcdafec64
| code segment            = base 0x0, limit 0xfffff, type 0x1b
| = DPL 0, pres 1, def32 1, gran 1
| processor eflags        = resume, IOPL = 0
| current process         = 28 (swi8:tty:sio clock)
| trap number             = 12

The second was:

| panic: ufs_dirbad: bad dir
| cpuid = 0;

These panics are copied from /var/log/messages.

I had run memtest about 20 times and it didn't find any errors, so I
think the RAM should be okay.

Has anyone hints?

If I can provide more information please let me know...

best regards,



Gordon Bergling <GBergling at>
PGP Fingerprint:  7732 9BB1 5013 AE8B E42C  28E0 93B9 D32B C76F 02A0
RIPE-HDL: MDTP-RIPE		"There is no place like"
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: not available
Url :

More information about the freebsd-current mailing list