calcru: negative time ... followed by freeze

Xin LI delphij at
Mon Jun 21 03:30:11 GMT 2004

On Sun, Jun 20, 2004 at 08:10:23PM -0400, Robert Watson wrote:
> I've now seen the following scenario happen several times in the last few
> days while doing testing and benchmarking: I run a multi-threaded test,
> such as super-smack, that causes a moderately high system load.  I then
> hit Ctrl-T or run top, or some other activity that forces calcru() to
> execute.  I will not infrequently get an extremely hard hang -- can't get
> to DDB using serial break, etc.  I don't remember it happening when using
> non-threaded apps, so I'm wondering if there's a poor interaction with
> KSE/scheduler/who knows what.
>  7:55PM  up 6 mins, 2 users, load averages: 1.37, 0.91, 0.43
> USER             TTY      FROM              LOGIN@  IDLE WHAT
> root             d0       -                 7:55PM     - w
> rwatson          p0       cboss             7:50PM     2 super-smack
> select-key
> hippy# top
> calcru: negative time of 1834075 usec for pid 654 (super-smack)
> ca~~
> In this case, I ran super-smack with the following parameters:
> hippy:/usr/tmp/super-smack> super-smack select-key.smack 15 1000
> This generates 15 workers, which should cause mysql to spawn off threads
> as well.  I'm running with stock libpthread on this system (slightly old)
> but an up-to-date kernel from CVS, GENERIC.
> Has anyone else seen this?

I saw calcru: negative time when I am having my system booted with a fresh
built kernel and world:

%uname -a
FreeBSD 5.2-delphij FreeBSD 5.2-delphij #77: Sun Jun 20 21:58:10 CST 2004     root@:/usr/obj/usr/src/sys/BEASTIE  i386

I have some local kernel modifications, which includes RFC3522
implementation ported from DragonFlyBSD (kern/68110 and some
further patch), some filesystem modifications (bin/61981) and
a PID allocation algorithm ported from NetBSD. However I believe
these changes does not contribute to this situation.

Additionally I have noticed that my system would silently freeze
when encounting heavy load with HTT enabled. My CPU is Pentium4
2.8-E. It seems that I am not the only one who have problem with
P4-2.8E, I think this should be taken into consideration, too.

Xin LI <delphij frontfree net>
See complete headers for GPG key and other information.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: not available
Url :

More information about the freebsd-current mailing list