Problems installing FreeBSD with 3ware 9500S-4LP

Patrick Hurrelmann outi at
Fri Jun 18 18:10:28 GMT 2004

On Fri, 18 Jun 2004 10:27:47 -0700 (PDT)
Doug White <dwhite at> wrote:

> Please don't crosspost -questions and other lists. I've removed it from
> the cc:.

ok, noticed that.

> > finally i received my new raid-controller, bu i have problems installing
> > FreeBSD on it :/
> >
> > I tried different releases and current snapshots...
> The twa driver is still very new. It just came out a few weeks ago, I
> think. I haven't seen one of those cards yet and we have a lot of 3ware
> here.
> Whats the RAID config?

I forgot to include that. Shame on me.
4x 120GB, 7200rpm, 8mb chache WesternDigital Disks are configured as one Raid 5 array. 

> > 5.1-Release
> > w ACPI: Loading twa.ko (binary distribution of for 5.2) in 		sysinstall failes.
> > w/o ACPI: same as w ACPI.
> I wouldn't expect this to work.

I tried that, as download page on 3ware says (FreeBSD 5.1, but i excpect that this is an error)
> > 5.2-Release
> > w ACPI: loaded twa.ko in sysinstall.
> > 	install went ok, on next reboot it just halts after BTX-Loader.
> > 	I cannot load twa.ko in loader.
> > w/o ACPI: same as w ACPI.
> Hm, sounds like the loader is getting corrupted. Try booting the install
> CD, breaking out of the loader countdown and run these commands
> (untested):
> unload
> set rootdev=disk1s1a (or whatever disk you put freebsd on)
> boot /boot/kernel/kernel

No, i think i didn't make it clearly enough. It halt on BTX-Loader.
I don't to the "real" loader. I don't see what modules it loads, etc.
I'll reboot an post the exact message i see.

> >
> > 5.2.1-Release
> > identical to 5.2 Release.
> >
> > 5.2-CURRENT-20040420
> > w ACPI:	install went ok, on next reboot the following message scrolls 		the screen and it reboots:
> > 	"Console internal keyboard/video" (or sth. like that)
> > w/o ACPI: same as w ACPI.
> >
> > 5.2-CURRENT-20040504
> > identical to 5.2-CURRENT-20040420
> >
> > 5.2-CURRENT-20040617
> > identical to 5.2-CURRENT-20040420
> >
> > I attached a normal and a verbose-dmesg.
> I'm suspecting two problems:
> 1. Volume was not created correctly so the loader binary is corrupted
> 2. The twa Int13 handler doesn't like how boot2 is loading the loader
> binary, which shouldn't happen.
> I'd check for a twa firmware update; these sound like firmware or
> firmware/BIOS issues.

twa.ko from 3ware dowload-site included new firmware. The controller has been updated automatically.

I have second ide-disk with a some day old current. I can mount the partitions created during install. All seems to be ok.

I tried a install with twa.ko of current, but it panics with an page-fault everytime i load the module through sysinstall.
> -- 
> Doug White                    |  FreeBSD: The Power to Serve
> dwhite at          |

More information about the freebsd-current mailing list