Realtek RT8139 (onboard) - failed to receive packet in loopback mode

Bill Paul wpaul at FreeBSD.ORG
Thu Jun 17 20:04:27 GMT 2004

> >
> >re0 at pci0:9:0:   class=0x020000 card=0x813910ec chip=0x813910ec rev=0x20 

Rev 0x20 == 8139C+

> Interesting.  I have come across 2 motherboards now that have onboard 
> Realteks of some sort, similar to what you see.


> rl0 at pci1:4:0:   class=0x020000 card=0x813910ec chip=0x813910ec rev=0x10 
Rev 0x10 == plain 8139 (without the plus)

You do _NOT_ have the same chip. Stop trying to relate your problems
to his. They have nothing to do with each other. Your attempt to
find similarities where none exist is counter-productive. Knock it

> Yet, one works as expected, the other half works in that the switch sees a 
> lot of FCS errors as if there were a duplex mismatch, despite both sides 
> being autoneg. (I tried various manual configs as well on both sides 
> without change). This is on stable, but the same problem was happening on 
> CURRENT when I tried to see if the re driver would see it, it did not.  The 
> only difference I see from your NIC and mine are the revs, yet the onboards 
> on the 2 motherboards I have refuse to work without generating lots of errors.

I don't know what your problem is, and you have not provided enough
data to figure it out. (Just how do you know there are many FCS errors
anyway. How did you meature them? Did you test performance too? If
so, how did you do that? What switch do you have?)


-Bill Paul            (510) 749-2329 | Senior Engineer, Master of Unix-Fu
                 wpaul at | Wind River Systems
              <adamw> you're just BEGGING to face the moose

More information about the freebsd-current mailing list