misc/63204: /dev/mixer broken with ESS Maestro-2

John strgout at unixjunkie.com
Tue Jun 15 21:11:09 GMT 2004

i've started working on this a little more and seem to have found a pattern.
First off 4.10 has all the same problems that 5.2.1 and current have. I have not
tried 4.9, but someone told me they had the same problems with 4.9.
This is what i've noticed when i boot 4.8 kernel and run a 4.10 userland sound
works fine. I did notice this in the dmesg though which is different from the

pcm0: <ESS Technology Maestro-2E> port 0xfc00-0xfcff irq 11 at device 12.0 on pci0
pcm0: agg_rdcodec() RW_DONE timed out.
-> pcm0: will perform cold reset. <-
pcm0: <Asahi Kasei AK4540 ac97 codec>

Note the will perform cold reset. I don't see this with 4.10 or current and
from looking at the bugreport no one else does either.
i tried removing this if statment (but nothing between it) from maestro.c

/* if (bus_space_read_1(ess->st, ess->sh, PORT_CODEC_STAT)
            & CODEC_STAT_MASK) { */


but it still didn't work with 4.10. Well maybe this is enough info for someone
with a little more clue to look into this. Also could someone assign this to 
sound@ assuming that is the correct place for this.

More information about the freebsd-current mailing list