acpi changes break ath0 and ums0

David Gilbert dgilbert at
Tue Jun 15 01:38:07 GMT 2004

>>>>> "Daniel" == Daniel O'Connor <doconnor at> writes:

Daniel> -----BEGIN PGP SIGNED MESSAGE----- Hash: SHA1

Daniel> On Sun, 14 Mar 2004 17:04, David Gilbert wrote:
>> Interestingly, unplugging ums0 and replugging it into another (not
>> the same) usb socket makes things work again.  The only dmesg
>> output is:
>> ath0: device timeout
>> Now... I suspect that this may be an ACPI issue ... since it seems
>> that the wireless card is partially shut down.
>> My current try is to cvsup again ... looks like new changes
>> today... and see if's solved.

Daniel> Try going back to v 1.14 of sys/dev/acpica/acpi_pci_link.c

Daniel> Worked for me to get my bfe working again.

Something was comitted to the cvs tree today about interrupt routing
and acpi.  I got that version and it appears to work.


|David Gilbert, Independent Contractor.       | Two things can only be     |
|Mail:       dave at                    |  equal if and only if they |
|                              |   are precisely opposite.  |

More information about the freebsd-current mailing list