Thinkpad panic woes (was Re: CDRW causes Thinkpad T41 to panic)

Daniel Eischen eischen at
Thu Jun 10 19:36:10 GMT 2004

On Thu, 10 Jun 2004, Alexander Marx wrote:

> Daniel Eischen wrote:
> > My drive is on ata1-master, not the slave.  From what I can see,
> > the failure for ata1-slave at boot up isn't a problem because
> > there is no device present on that channel.  Once booted, I was
> > able to use xmcd and play an audio CD on it, so it is at least
> > working well enough for that.  5.2.1-RELEASE doesn't show the
> > "ata1-slave FAILURE - ATAPI_IDENTIFY" message and booted just
> > fine -- there were no "Memory modified after free" messages
> > (and panic).  I did have to disable ACPI in order to get
> > 5.2.1-RELEASE to work, though.
> > 
> well, i've the very same problem here with a my thinkpad t40.
> 5.2.1 works only w/o acpi, 5.2 and -CURRENT (as of yesterday)
> do not work at all with the cd/dvd present.
> the panic w/ trace and a dmesg (boot -v but w/o cd/dvd)
> is available here:
>       [0]
> > The "memory modified after free" bothers me.  It indicates
> > that either something is running amok with pointers, or that
> > references are still being made after memory is free()'d.
> > I've been trying to track it down, but I haven't had any
> > luck so far.  Anyone have any ideas on how to debug this?
> > 
> i tried to track the alloc/free's with some printf's
> and discovered, that setting the retries=1 in ata-all.c
> fixed it the panic in -current; my -current then boots with
> acpi enabled and the cd/dvd present, without problem.

Yeah, that's where I was looking.  My theory is that after
the first try fails, memory is freed, but re-used in the
second (re)try.

Dan Eischen

More information about the freebsd-current mailing list