ndis problems (T40, Centrino, upgraded 06.03)

Paulius Bulotas paulius at devnull.lt
Thu Jun 3 20:30:46 GMT 2004


today I upgraded to -current on my laptop (T40, Centrino). Everything
seems to work ok - suspend/resume on AC works like a charm (just tried
now on battery with sound playing - got dead mouse in X, then crash after
The bad thing, that ndis0 stopped working - from the point of luser, it
can't turn on the radio (or wireless indicator ;). Actually, it flashes
for half of second. Everything looks like:
root at t40:~# ./if
pci0: Failed to set ACPI power state D3 on (null): AE_BAD_PARAMETER
ndis0: <Intel(R) PRO/Wireless LAN 2100 3B Mini PCI Adapter> mem 0xc0200000-0xc02
00fff irq 11 at device 2.0 on pci2
can't re-use a leaf (ESS_ID)!
ndis0: NDIS API version: 5.1
ndis0: Ethernet address: 00:04:23:72:4a:75
ndis0: 11a rates:
ndis0: 11b rates: 11Mbps 1Mbps 2Mbps 5.5Mbps 11Mbps
ndis0: set mclist failed: 6
ndis0: set filter failed: 6
ndis0: set mclist failed: 6
ndis0: set filter failed: 6
ndis0: set mclist failed: 6
ndis0: set filter failed: 6
root at t40:~# ifconfig ndis0
	inet6 fe80::204:23ff:fe72:4a75%ndis0 prefixlen 64 scopeid 0x3 
	ether 00:04:23:72:4a:75
	media: IEEE 802.11 Wireless Ethernet autoselect
	status: no carrier
	ssid ""
	channel 6 authmode OPEN powersavemode OFF powersavesleep 100
	rtsthreshold 2312 protmode CTS
	wepmode MIXED weptxkey 1
	wepkey 1:104-bit

no ssid, no carrier... the 'if' script configures interface, up's it and
sleeps 15 seconds, then checks if it's associated (and there it's not).

Then I tried ipw driver from http://damien.bergamini.free.fr/ipw/ .
Surprisingly it worked (it didn't on my month old -current ;), but after
loading if_ipw, usb dies ;) So this leaves me hoping that ndis0 will
start working again (after downgrade, or after miracle from Bill Paul ;)

TIA ;)

More information about the freebsd-current mailing list