5.2.1 on EPIA M1000 board

Robert Downes nullentropy at lineone.net
Tue Jun 1 09:06:24 PDT 2004

Eric Anderson wrote:

> Robert Downes wrote:
>> I have had an awful weekend trying to make sense of wild errors that 
>> FreeBSD has been throwing on my VIA EPIA M1000 board.
>> 5.0 seemed to be going fine, until I tried to make buildworld using 
>> 5.2.1 sources. Then it crashed and reset halfway through. The second 
>> attempt worked, so I built and installed a 5.2.1 kernel. Then the fun 
>> began.
>> 5.2.1 would not accept my hard disk. Attepmting to boot normally, or 
>> mounting drives after booting into single-user-mode, would cause a 
>> stream of errors.
>> Thinking the crash had screwed my hard disk data structure, I did a 
>> fresh install of 5.2.1 from the release ISO from the FTP site. Booted 
>> fine on a Pentium 4 machine, but went beserk again on my EPIA board.
>> The error I'm getting looks like this:
>> ad0: FAILURE - WRITE_DMA status=11 <DSC,ERROR> error=84<ICRC,ABORTED> 
>> LBA=4127103
>> Such messages would stream up the screen, the drive crunching wildly. 
>> Any successful access (booting from a kernel.old 5.0 kernel, for 
>> instance) would complain about the filesystem being dirty, and leave 
>> the system read-only until fsck was run. fsck would run, but would 
>> find dozens of assorted errors which it could not correct.
>> I posted this to freebsd-questions, and someone replied with 
>> something along the lines of 'me too' - they say that they can run 
>> 5.2.1 on a Compact Flash card, but will get wild problems too if they 
>> attempt to boot it from any hard disk.
>> Also, should it be of any interest, I can only run 5.0 if I disable 
>> UDMA access to the Primary IDE Master in my BIOS settings. FreeBSD 
>> obligingly drops to PIO mode. Any ideas on this?
> Do you have a 40-wire cable plugged into a drive that wants to use an 
> 80-wire cable?
> I assume you mean you have an M10000, right?
> That same drive works fine in a different system?

The drive is a Toshiba MK8025GAS 2.5" 80GB laptop drive. It is connected 
to my EPIA M10000 using a 2.5" to 3.5" converter cable.

Using the same drive (but a slightly different converter cable) on a 
Pentium 4 machine, I got the following error when trying to run FreeBSD 
5.0 installation CD:

    ad0: READ command timeout tag=0 serv=0 - resetting
    ata0: resetting devices

and the machine would just hang there, the drive light accessing 
constantly. To get past that problem I disabled UDMA mode for the IDE 
controller in the BIOS settings, and then FreeBSD 5.0 would detect the 
drive and access it with PIO mode.

This installation of FreeBSD 5.0 would then also run on my EPIA in PIO 
mode quite happily (and is doing so right now).

The problem comes with 5.2.1. FreeBSD 5.2.1 runs on the Pentium 4 with 
UDMA mode disabled (I don't remember if I tested with UDMA enabled) - 
everything boots normally, and logins are accepted, etc. But on my EPIA, 
5.2.1 goes beserk with the messages mentioned above:

    ad0: FAILURE - WRITE_DMA status=11 <DSC,ERROR> 
error=84<ICRC,ABORTED> LBA=4127103

and this happens whether or not UDMA mode is enabled.

Please let me know if you need more information.

(And, Eric, let me know if you get this but it does not make it onto the 
current list... I'm always getting bounced because I receive list 
messages on one address, but I reply with another.)


More information about the freebsd-current mailing list