5.2.1 on EPIA M1000 board

David Xu davidxu at freebsd.org
Wed Jun 2 03:57:20 GMT 2004

Robert Downes wrote:
> I have had an awful weekend trying to make sense of wild errors that 
> FreeBSD has been throwing on my VIA EPIA M1000 board.
> 5.0 seemed to be going fine, until I tried to make buildworld using 
> 5.2.1 sources. Then it crashed and reset halfway through. The second 
> attempt worked, so I built and installed a 5.2.1 kernel. Then the fun
> began.
> 5.2.1 would not accept my hard disk. Attepmting to boot normally, or 
> mounting drives after booting into single-user-mode, would cause a 
> stream of errors.
> Thinking the crash had screwed my hard disk data structure, I did a 
> fresh install of 5.2.1 from the release ISO from the FTP site. Booted 
> fine on a Pentium 4 machine, but went beserk again on my EPIA board.
> The error I'm getting looks like this:
> ad0: FAILURE - WRITE_DMA status=11 <DSC,ERROR> error=84<ICRC,ABORTED> 
> LBA=4127103
> Such messages would stream up the screen, the drive crunching wildly. 
> Any successful access (booting from a kernel.old 5.0 kernel, for 
> instance) would complain about the filesystem being dirty, and leave the
> system read-only until fsck was run. fsck would run, but would find 
> dozens of assorted errors which it could not correct.
> I posted this to freebsd-questions, and someone replied with something 
> along the lines of 'me too' - they say that they can run 5.2.1 on a 
> Compact Flash card, but will get wild problems too if they attempt to 
> boot it from any hard disk.
> Also, should it be of any interest, I can only run 5.0 if I disable UDMA
> access to the Primary IDE Master in my BIOS settings. FreeBSD obligingly
> drops to PIO mode. Any ideas on this?

This sounds like a cable problem, are you using ATA33 cable ?
Sometimes ago, I have installed 5.2.1 on EPIA-MII without any problem.
I will try if I can install it on my EPIA-SP and CN400.

David Xu

More information about the freebsd-current mailing list