ndis on Asus M2400N

sebastian ssmoller sebastian.ssmoller at gmx.net
Fri Jan 30 13:00:53 PST 2004

many thanks for that hint !  ... it seems to work for me to :-)

i said "seems" because i have no wlan access point available at the
moment to really test it. 
but i compiled if_ndis again, loaded the module and started the dhclient
on ndis0  -  no panic :) 

the output i get is:
ndis0 : set auth failed: 19
ndis0 : set auth failed: 19
ndis0 : link up
ndis0 : failed to get bssid
ndis0 : link down

but i guess this is ok because of missing link ...

i will do the final test on monday when i have a wlan access point
availaible and i will report my experiences then.


On Fri, 2004-01-30 at 21:18, Autrijus Tang wrote:
> Hi there, I've just read your post in -current archives about Asus
> M2400N's kernel panic with ndis.  I have encountered the same problem
> using Asus' drivers, but IBM's centrino driver worked like a charm on
> the same computer.
> I followed the instructions here:
> http://mailbox.univie.ac.at/~le/thinkpadt40/
> And downloaded the XP/2000 driver:
> ftp://ftp.software.ibm.com/pc/pccbbs/mobiles/iprowiir.exe
> I've used the XP one, which worked beautifully.  Much kudos for the
> Project Evil... Now if snd_ich can work again, I'll be truly happy. :-)
> HTH,
> /Autrijus/

More information about the freebsd-current mailing list