mounting msdos partitions buggy?

Greg J. xcas at
Fri Jan 30 06:00:36 PST 2004

Greg J. wrote:
>  > Have you verified that your FAT partition is not corrupted by running
>  > fsck_msdos against it?
> fsck_msdosfs doesn't even seem to recognize it.. I know there's nothing 
> wrong with the partition.
> I even did a clean install of FreeBSD & Win2k... and moved the fat32 
> partition to another drive. But I still get the same behaviour.
> localhost# fsck_msdosfs /dev/ad1s5
> ** /dev/ad1s5
> backup doesn't compare to primary bootblock
> localhost# mount -t msdos /dev/ad1s5 /msdos
> localhost# fsck_msdosfs /msdos
> ** /msdos (NO WRITE)
> Invalid signature in boot block: ffff

Ok.. I installed the i386 version & all is fine.. so it seems to be the 
amd64 version that has trouble with non-UFS/UFS2 partitions.

For the people on the amd64 mailing list.. has anyone ran into where 
copying/moving/creating files to/on a MSDOS partition results in the 
filename being renamed to where the last character of the filename is 
added twice?

example: cp /etc/rc.conf /msdos (would end up as 'rc.conff' in /msdos)

then.. if you tried to rename it back to rc.conf in /msdos.. it would 
say the file already exists when it doesn't.

More information about the freebsd-current mailing list