ACPI causing trouble for X in 5.2

Peter Schultz pmes at
Sat Jan 17 10:12:42 PST 2004

David Cramblett wrote:
> Robert Watson wrote:
>>On Fri, 16 Jan 2004, David Cramblett wrote:
>>>>>>I have problem with X on 5.2-RC2. Sometimes the whole
>>>>>>system hangs when I start X by startx or 'setpmac mls/equal startx'
>>>>>>(with MAC policies loaded). In about 30% of attempts it hangs on
>>>>>>XFree startup messages and hard reset is required.
>>>>>>The problem occurs a little bit too often for some unrelated
>>>>>>accident and it doesn't occur at all on 5.1-RELEASE (the same
>>>>>>hardware and configuration).
>>>>>>Does anyone have similar problem ?
>>>>>Yes, see my post from earlier today called "Can't shutdown, logout, or
>>>>>restart cleanly."  I have not run 5.1-RELEASE before, so I can't say
>>>>>if it didn't happen there, but it definitely happens with
>>>>>5.2-CURRENT.  I'm at my wit's end trying to find out why!
>>>>Per a post I received on, try booting up with ACPI turned
>>>>off.  This can be done in 5.1 and later by choosing option 2 in the >boot
>>>>menu (Boot FreeBSD with ACPI disabled).  Once I did this, it worked >like
>>>>a champ.  I'm not sure why earlier versions may not have been affected
>>>>by this or if it only affects certain hardware.
>>>>Let me know if this worked for you.
>>>I have the same problem on two builds of 5.2, one is a Sony Vaio 
>>>PCG-F360 Laptop (PII 400MHz) and the other is a newer P4 system with 
>>>Asus mother board.  Both worked fine with 5.1 and both broke with 5.2. 
>>>I was able to work around this problem by booting up with ACPI disabled. 
>>> Is there a known issue with ACPI that is being worked on for 5.2 or
>>>did someone already submit a bug report?  Thanks, David
>>I was seeing this on my Dell Latitude notebook from a couple of years ago
>>(C600).  I found that the problem "went away" when I switched off either
>>ACPI or device apic, so it looks like it's basically an interrupt problem
>>of some sort.  I'm running with the r128 kernel module for DRI, and John
>>Baldwin suggested that it might be part of the problem.  I've also been
>>experiencing continuing ATA problems, so it may well be that a combination
>>of ACPI and apic changes has resulted in improper handling/routing/... of
>>interrupts on the box.
>>You might want to check and see if there are any BIOS upgrades available
>>for your system -- as ACPI support evolves, older systems with more
>>questionable ACPI sometimes work less well.  A number of vendors have
>>released BIOS updates to address this.
> Seems kinda strange that it would work fine in 5.1 and then break in 
> 5.2, if it were hardware/bios related.  Keep in mind, one of my systems 
> is less than a year old P4 system (you seem to just be referencing my 
> older laptop), so were not just talking about old pre-ACPI hardware/bios 
> either.  I may be wrong, but it seems something has changed for ACPI 
> between 5.1 and 5.2, either in the FreeBSD implementation or in the 
> specification that would require a BIOS update on my newer hardware and 
> make the older hardware need it disabled.

In November John Baldwin changed how interrupts are handled and this 
shook up ACPI support for a lot of people.  I've created the following 
in an effort to help people sort through the difficulties:


More information about the freebsd-current mailing list