ACPI causing trouble for X in 5.2

David Cramblett dcramble at
Fri Jan 16 09:44:40 PST 2004

Trey Sizemore wrote:

 >> Jaroslaw Nozderko wrote:
 >>> OS: FreeBSD 5.2-RC2 (MAC - biba,mls)
 >>> Hi,
 >>> I have problem with X on 5.2-RC2. Sometimes the whole
 >>> system hangs when I start X by startx or 'setpmac mls/equal startx'
 >>> (with MAC policies loaded). In about 30% of attempts it hangs on
 >>> XFree startup messages and hard reset is required.
 >>> The problem occurs a little bit too often for some unrelated
 >>> accident and it doesn't occur at all on 5.1-RELEASE (the same
 >>> hardware and configuration).
 >>> Does anyone have similar problem ?
 >>> Regards,
 >>> Jarek
 >> Yes, see my post from earlier today called "Can't shutdown, logout, or
 >> restart cleanly."  I have not run 5.1-RELEASE before, so I can't say
 >> if it didn't happen there, but it definitely happens with
 >> 5.2-CURRENT.  I'm at my wit's end trying to find out why!
 >Per a post I received on, try booting up with ACPI turned
 >off.  This can be done in 5.1 and later by choosing option 2 in the >boot
 >menu (Boot FreeBSD with ACPI disabled).  Once I did this, it worked >like
 >a champ.  I'm not sure why earlier versions may not have been affected
 >by this or if it only affects certain hardware.

 >Let me know if this worked for you.

I have the same problem on two builds of 5.2, one is a Sony Vaio 
PCG-F360 Laptop (PII 400MHz) and the other is a newer P4 system with 
Asus mother board.  Both worked fine with 5.1 and both broke with 5.2. 
I was able to work around this problem by booting up with ACPI disabled. 
  Is there a known issue with ACPI that is being worked on for 5.2 or 
did someone already submit a bug report?



More information about the freebsd-current mailing list