Can you open this OpenOffice document ? Windows can, Knoppix can but not FBSD!

Dany dany_list at
Sat Jan 10 23:24:12 PST 2004

The attached openoffice document (also available at has been created under OpenOffice 1.1 
on a Windows platform. I used to be able to open it under FreeBSD 5.2RC2 
but not anymore.

Just to make sure I rebooted with a Knoppix LiveCD and this time I was 
able to open this file.

So to summarize :
- OpenOffice 1.1 / Win2K -> OK
- OpenOffice 1.1 / Knoppix 3.2 -> OK
- OpenOffice 1.1 / FreeBSD 5.2RC2 ->  ERROR

I thought it was a font problem (arial) so I copied the font directory 
from the windows machine into a new TrueType dir and issued mkfontdir 
command from there.

As described on the Handbook I used the following to temporally enable 
this new font dir.
% xset fp+ /usr/X11R6/lib/X11/fonts/TrueType
% xset fp rehash

Now when I start OpenOffice and  create a blank document I can see the 
new fonts.

So when I do :

cd /home/alpha/OpenOffice

and open my tips52-bug.sxw file, the progress bar goes up to 100% and then a popup window displays : 
"An unrecoverable error has occurred.  All modified files have been saved and can probably be recovered at program restarts."

The console window shows :
crash_report : not found
Fatal exception : Signal 11
Abort trap (core dumped)

I tried to load a previous version of this document and it worked under FreeBSD. Only this one doesn't work !

PS: When I rebooted the first time using "shutdown -r now" I received a : FATAL TRAP 9: general protection fault ... don't know if this is related.

Please let me know if you're able to open the document using 5.2RC2 and OpenOffice 1.1.0. How can I debug this problem ?

Thank you


More information about the freebsd-current mailing list