Open-motif installation

raver raver at
Wed Jan 7 17:24:09 PST 2004

Hi mates!
Since one month ago is being impossible to install open-motif. Every  
time I tried it I got the same error:

===>  Applying FreeBSD patches for open-motif-2.2.2_1
sed: /usr/ports/x11-toolkits/open-motif/work/openmotif-2.2.2/doc/man/ 
XmPrintSetup.3: Too many open files
sed: /usr/ports/x11-toolkits/open-motif/work/openmotif-2.2.2/doc/man/ 
XmPrintShell.3: Too many open files
*** Error code 1

Stop in /usr/ports/x11-toolkits/open-motif.
** Command failed [exit code 1]: /usr/bin/script -qa /tmp/ 
** Fix the problem and try again.
** The following packages were not installed or upgraded (*: 
skipped / !:
       ! x11-toolkits/open-motif       (unknown build error)

First I checked my /etc/login.conf to be sure openfiles tag in default  
section was set to unlimited. Yes it was.

Then I set kern.maxfiles to 20000 via sysctl command and modifying the  
file /etc/sysctl.conf to set automatically at boot time.

Looking for a solution in mailing lists archives I didn't find another  
case of that error, it's extrange... Anybody have an idea what could be  
the mistake?

Thanks in advance,
	" I chose not to choose life: I chose something else.
	And the reasons? There are no reasons.
	Who need reasons when you've got BSD? "

		Ricard Pascual Diaz AKA 'raver'
		raver at

More information about the freebsd-current mailing list