5.3-BETA hangs on Acer TM290 series Laptop

Robert Klein RoKlein at roklein.de
Tue Aug 31 00:31:16 PDT 2004

On Montag, 30. August 2004 17:30, Gavin Atkinson wrote:
> On Sat, 2004-08-28 at 11:23, Robert Klein wrote:
> > I tried to boot 5.3-BETA on my TM291 (Centrino,
> > "hotpluggable" DVD/CDRW-Combo, bg2200 WLAN).
> >
> > It hangs after the first few lines of boot messages and has
> > to be rebooted the hard way (press power-off for four
> > seconds)..
> Try switching any "Plug and Play OS" type options in your BIOS
> to "No" or similar. This fixes at least one laptop I've tried.

There are no "Plug an Play" options in the BIOS. It is one of 
those "I know better" BIOSes...

> Also, try breaking to the loader prompt at the Beastie menu,
> and typing
> set hw.pci.enable_io_modes="1"
> boot

No, this does not help, but setting it to "0" gets me one step 
further.  The boot process succeeds at the PCI detection phase 
(or whatever it is called) and proceeds through agp0, pci0 again 
(display), uhci0, and gets a fatal trap 12 at (or after) uhci1.

The output from "boot -v" and output of "trace" command is below.
Btw, this is still using the 5-3-beta1 snapshot from AUG-27 from 

PS: I just tried the same with 5.2-RELEASE and I get the trap at 
the same place...

Thanks and best regards,

--- output from "boot -v" with set hw.pci.enable_io_modes="0" ---
usb0: <Intel 82801DB (ICH4) USB Controller USB-A> on uhci0
usb0: USB revision 1.0
uhub0: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
uhci1: <Intel 82801DB (ICH4) USB controller USB-B> port 
0x1600-0x161f at device 19.1 on pci0
uhci1: Reserved 0x20 bytes for rid 0x20 type 4 at 0x1600
$PIR: Fount IRQ 10 for link 0x63 from 5 10 11

Fatal trap 12: page fault while in kernel mode
cpuid = 0; apic id = 00
fault virtual address  = 0xe7e02
fault code             = supervior read, page not present
instruction pointer    = 0x8:0xc00e9d05
stack pointer          = 0x10:0xc10219ec
frame pointer          = 0x10:0xc10219ec
code segment           = base 0x0, limit 0xfffff, type 0x1b
                       = DPL 0, pres 1, def32 1, gran 1
processor eflags       = interrupt enabled, resume, IOPL = 0
current process        = 0 (swapper)
[thread 0]
Stopped at      0xc00e9d05:     cmpb    %cs:0x1(%esi),%bl
db> trace
kernbase(c0812ff4,c20,c07f2384,a0b,e9) at 0xc00e9d05
end(cb9d08c4,c4f6ec8b,81067540,ffffe5,e67f2400) at 0xc1021a44

More information about the freebsd-current mailing list