APIC causes vr0 watchdog timeouts and Interrupt storms

Nate Lawson nate at root.org
Sun Aug 29 16:26:04 PDT 2004

Christian Hiris wrote:
> On Sunday 29 August 2004 06:49, Justin Settle wrote:
>>I recently installed 5.3-BETA.  After booting, I found was unable to use
>>my usb mouse or my ethernet (Via-rhine).  I started tinkering with the
>>kernel and found that if I disabled APIC, this system worked without
>>ethernet issues or mouse isssues.  After talking with some people they
>>suggested I post boot -v, dmesg's of the different kernels so here they
>>The first thing I tried was a GENERIC with SMP commented out.  It had
>>the same issues as GENERIC:
>>Copyright (c) 1992-2004 The FreeBSD Project.
>>Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
>> The Regents of the University of California. All rights reserved.
>>FreeBSD 5.3-BETA2 #0: Sat Aug 28 23:18:57 EDT 2004
>>    root at amon.quaggaspace.org:/usr/obj/usr/src/sys/GENERICNOSMP
> [snip]
>>acpi link set: _CRS failed for link \\_SB_.PCI0.ALKB - AE_NULL_ENTRY
>>acpi link set: curr irq 0 != 21 for \\_SB_.PCI0.ALKB (ignoring)
>>unknown: _SRS failed, irq 21 via \\_SB_.PCI0.ALKB

This has been fixed in -current for a while.  I just MFCd the fix to 
5.3.  Let me know if it doesn't fix your problem.


More information about the freebsd-current mailing list