cvsup on amd64 just broke today

David O'Brien obrien at
Sun Aug 29 15:53:24 PDT 2004

On Mon, Aug 09, 2004 at 08:54:43PM -0500, Conrad J. Sabatier wrote:
> On 10-Aug-2004 Doug White wrote:
> > On Mon, 9 Aug 2004, Conrad J. Sabatier wrote:
> >> # make update
> >> --------------------------------------------------------------
> >> >>> Running /usr/local/bin/cvsup
> >> --------------------------------------------------------------
> >> /usr/local/libexec/cvsup-static.i386.bin: 1: Syntax error: "("
> >> unexpected
> >> *** Error code 2
> > 
> > Can you run cvsup manually? It appears to be trying to execute a
> > binary as a shell script here.
> Tried that, got the same result.
> I hadn't noticed it before, but it does strike me as odd that the
> binary package for amd64 would include a file with "i386" in the name,
> and which is, in fact, an ELF 32 binary.

Why is it odd?!?
The ability to run legacy 32-bit x86 binaries under a 64-bit OS at
full-speed is one of the huge capabilities AMD brought with this
architecture.  Unless a binary does 64-bit math or addresses >4GB of
memory why does something need to be 64-bit???

The fact that all Open Source OS's have a 64-bit userland on all their
64-bit platforms that grew up from 32-bit CPU's shows how unsophisticated
our build framework is.  "64-bit" Solaris today is really a 64-bit kernel
and mostly 32-bit userland.

> Did something change today that would effect the handling of such a
> file, perhaps?

Nope, it has been a 32-bit 'i386' binary since the day the port started
supporting FreeBSD/AMD64.

-- David  (obrien at

More information about the freebsd-current mailing list