Boot code broken in some way in recent current (Was: Panic at boot)

John Baldwin jhb at
Mon Aug 23 11:10:03 PDT 2004

On Saturday 21 August 2004 04:35 pm, Doug White wrote:
> On Fri, 20 Aug 2004, Roman Kurakin wrote:
> >     At first I have two SMP system (Dual) one that boots normaly and one
> > that
> > goes to panic (the older pc).
> >    I've setup finaly serial console to that system, so here is more
> > detailed output:
> >
> > OK boot -Dhv
> > /boot/kernel/acpi.ko text=0x406a8 data=0x1bc4+0x110c
> > syms=[0x4+0x72d0+0x4+0x9754]
> Have you tried booting without enabling ACPI?  The ACPI tables seem to
> think you have two APs and no BSP.

ACPI tables have no concept at all of a BSP.  We infer the BSP by checking the 
APIC ID of the CPU we are currently executing on when enumerating CPUs.

> Also check the BIOS and set the MPTable version to 1.4, and upgrade the
> BIOS itself if there is an update.

Since it worked before the recent loader change, I doubt this will make a 
difference.  More likely is that the code picked a bad memory address to 
install the AP trampoline into for some reason.

John Baldwin <jhb at>  <><
"Power Users Use the Power to Serve"  =

More information about the freebsd-current mailing list